summaryrefslogtreecommitdiff
path: root/dev-python/pyopenssl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-28 20:40:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-28 20:40:51 +0000
commit9c417bacd51da6d8b57fa9f37425161d30d4b95b (patch)
tree47c9d6e4243f39a1f48afd54c969b65b00a5c649 /dev-python/pyopenssl
parentd934827bf44b7cfcf6711964418148fa60877668 (diff)
gentoo resync : 28.11.2020
Diffstat (limited to 'dev-python/pyopenssl')
-rw-r--r--dev-python/pyopenssl/Manifest2
-rw-r--r--dev-python/pyopenssl/pyopenssl-20.0.0.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/pyopenssl/Manifest b/dev-python/pyopenssl/Manifest
index adf23c039dfc..76e45216edd5 100644
--- a/dev-python/pyopenssl/Manifest
+++ b/dev-python/pyopenssl/Manifest
@@ -1,3 +1,5 @@
DIST pyOpenSSL-19.1.0.tar.gz 160510 BLAKE2B e6e39f860221a2696aa3fa32ac89ed48e34b18e4accc366a86264d943a15a1b00ba1a0d8349550d1775d25836aa5d214e1e3fe4ec0a9c0f6d5ab00cd9fede633 SHA512 4acd96f287d72eb11bd812697d28cd6eb6a96a4653248b65f967187830a6b17cc1254775a18a3405469f3d45abdae6f02d165f2f35f035f3174c2826fba82916
+DIST pyOpenSSL-20.0.0.tar.gz 173786 BLAKE2B 3fb1e90e20b3e083fc93f6dc8a54fb54e15ceb38c4d2e84e2d7d68bb56f9e3828cd264e3554f25465e858687e74a7f20b91216fb7a0b4b2c656ea86423cd3442 SHA512 26e8a64d53a35434ad4bf5ef50ed5c37d7b92b0db971a2103dcafea56a0b377d67333af630a31405a97cf2cffddde320907b4950ed336a8321391854bcd2c50a
EBUILD pyopenssl-19.1.0-r1.ebuild 1395 BLAKE2B 29ec3a4e7ca4ac8c60f6227046e80c136e12db62d493619e852cdd657a332543806e48915ee0b9613258427230e9b696d07d2295bb0ed80c837ffc5cfba91aa0 SHA512 1620336ea740370145277b48c4836d5b8d9e2c4f5d476d29c4c321194ca04adc04d1972d4278309b8dac65dd6bb8da0a1b14cb6e3689e41c3be88f8fd5a50952
+EBUILD pyopenssl-20.0.0.ebuild 1402 BLAKE2B 2ca98de775ce7d213f38ebf58ae0ade0f1afab3132b034bbaedc351436e3ca3b895e948e7238b3b0b5dfc7e0694ee2c2444ea3639868409d23ba6b3b22b4ee75 SHA512 907ca7f0a92aad565cc76483cfecd6f689162ec5cef244eae3c3e29641d08d3291b2a3046bc4b22fa9da9ec5e89ccfb9436d31282ccf0056695ac1240255f23e
MISC metadata.xml 481 BLAKE2B e25a44e19e9e7fb701742e1c4916a41a777efcaa046b8147510fc8d9d021cbaad9fb887d8df6769b91006acdc9418df6cec4ba20a78fdec88d26b7cc4ac5c2f0 SHA512 d568654867ca274e7c67a9b30a7f50e739309a22d78c3c1f06f4216a224b00e3a05be022920614befaf96a65ac55782966c9a1fd0ae88c806acc559af307ca38
diff --git a/dev-python/pyopenssl/pyopenssl-20.0.0.ebuild b/dev-python/pyopenssl/pyopenssl-20.0.0.ebuild
new file mode 100644
index 000000000000..b09f1b1bdec6
--- /dev/null
+++ b/dev-python/pyopenssl/pyopenssl-20.0.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 flag-o-matic
+
+MY_PN=pyOpenSSL
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Python interface to the OpenSSL library"
+HOMEPAGE="
+ https://www.pyopenssl.org/
+ https://pypi.org/project/pyOpenSSL/
+ https://github.com/pyca/pyopenssl/
+"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/six-1.5.2[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-3.2[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ virtual/python-cffi[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.0.1[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx doc \
+ dev-python/sphinx_rtd_theme
+
+python_prepare_all() {
+ # Requires network access
+ sed -i -e 's/test_set_default_verify_paths/_&/' tests/test_ssl.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ TZ=UTC pytest -vv || die "Testing failed with ${EPYTHON}" # Fixes bug #627530
+}