summaryrefslogtreecommitdiff
path: root/dev-python/pypdf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-19 20:08:27 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-19 20:08:27 +0000
commit2b2f431a0021b4787ca3c028cefb30ad81347778 (patch)
tree951e0155f53027c8fd29eaba26df4f08292668d5 /dev-python/pypdf
parentd725480af7cbc67d784e5d96f973fa41e9030123 (diff)
gentoo auto-resync : 19:01:2024 - 20:08:27
Diffstat (limited to 'dev-python/pypdf')
-rw-r--r--dev-python/pypdf/Manifest2
-rw-r--r--dev-python/pypdf/pypdf-4.0.0.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/pypdf/Manifest b/dev-python/pypdf/Manifest
index bea34dc02214..b10a84a08cac 100644
--- a/dev-python/pypdf/Manifest
+++ b/dev-python/pypdf/Manifest
@@ -1,4 +1,6 @@
DIST pypdf-3.17.4.gh.tar.gz 7976829 BLAKE2B c2b7aef937186aecf525729f336ad6d00a8bf40850be17cb450daba5d0100acc0b0c3f51ef242e3cf7ef710d5c40c9f334db94a372b6d6eb4f2270dc00dde156 SHA512 f687a2032f085dac9b920f881f2df9f96e4da2a8dcdd5f971d3601ab05ae4f9b5528d0155adcb5ef01c6d8ffdc4f3d79077706915851bad7868bf761d28c513a
+DIST pypdf-4.0.0.gh.tar.gz 7992828 BLAKE2B 97ab3783ab91ebc638b625fe39c3008516de82f1ac384a45ef27a06bb0b91a86a5fdc24efbb92644a4355743b24e86f68822858eef2df39a3b6415795276c7c4 SHA512 488adffc330bb372df245d2dfdaee357bcd4303cc33d7ee31fd7abc393ce366c78715ca4a6516795ada6b5517ca32fec5f24cdad15e0d2c109fa90ebd2f9b05c
DIST pypdf-sample-files-964fb47b0fbfa89864680582640ae4eedf143890.gh.tar.gz 11668924 BLAKE2B 0c7d8e7cfb2f9d06d7633d57b691ba473d33cfcb58d2f1f83661cef9d755340d05db8767771a385d0ba88aa904f84b8bc7eafdb5d4f614b7a21a2d138572316f SHA512 28070b575273b6fee3173e797ed5bac618f8e8aca16d0122dcf3b4b16cedbcad69b84a9bc4be65037695597bcc1fa7898cdf766c37915c49f880a0c6ca057e68
EBUILD pypdf-3.17.4.ebuild 1358 BLAKE2B 06c968d344aeb134c17141f789f938131b0d4555a9d00b11b52c8fcd71bdd9c5ed990eaf679ee56f123d99384a10b9cad6e70894a4a55da53bf6a3a5076b28de SHA512 57f571867687731a9d5dbd6f8e32c21345fb1fadd84879116a00102c00bf6934162f4c72154cafabe7c995d20bc64264571b7d6e28d74dab3f0cc05bb5c719e0
+EBUILD pypdf-4.0.0.ebuild 1467 BLAKE2B d700b7eced0e8007f5cf51fc60cee8c29844e3f2d13b6ac615bfc385b2e8d5831bfa82fc54373c46c56132c0bb537c04a573ba83b31465cda01000542ece8844 SHA512 696e58f22954df911dd35ab188c7460d3fcde6cb49013cb3e814d526a63b5eae1ffe3773df955ef1eaa09aba52b24793aafc48ccdeb3e30586b10076160c813f
MISC metadata.xml 373 BLAKE2B a829b7048eb3a95caeb1be83b6172603df6a031d40995294f2687bf3c3cb70e66fafb9ba8339d9979fc85f5936b9552963a8fcd072a20661fa78f3aa3c4b89c0 SHA512 775ac2de487f11fba1ea8d283b42b9ef56e42cd95ea11f50a06b099420e69c0567f65c506b14891ac641da90ea05ca70da4f8a3e4a028cf41bdbc823021dccfe
diff --git a/dev-python/pypdf/pypdf-4.0.0.ebuild b/dev-python/pypdf/pypdf-4.0.0.ebuild
new file mode 100644
index 000000000000..e314f1fdfa84
--- /dev/null
+++ b/dev-python/pypdf/pypdf-4.0.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+SAMPLE_COMMIT=964fb47b0fbfa89864680582640ae4eedf143890
+DESCRIPTION="Python library to work with PDF files"
+HOMEPAGE="
+ https://pypi.org/project/pypdf/
+ https://github.com/py-pdf/pypdf/
+"
+SRC_URI="
+ https://github.com/py-pdf/pypdf/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ test? (
+ https://github.com/py-pdf/sample-files/archive/${SAMPLE_COMMIT}.tar.gz
+ -> ${PN}-sample-files-${SAMPLE_COMMIT}.gh.tar.gz
+ )
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ >=dev-python/pillow-8.0.0[jpeg,jpeg2k,tiff,${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ tests/test_reader.py::test_decode_permissions
+ tests/test_workflows.py::test_text_extraction_layout_mode
+ # rely on -Werror
+ tests/test_utils.py::test_deprecate_no_replacement
+ tests/test_workflows.py::test_orientations
+ tests/test_writer.py::test_remove_image_per_type
+ # TODO: requires fpdf
+ tests/test_page.py::test_compression
+ tests/test_writer.py::test_merging_many_temporary_files
+)
+
+src_unpack() {
+ default
+ if use test; then
+ mv "sample-files-${SAMPLE_COMMIT}"/* "${S}"/sample-files/ || die
+ fi
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -o addopts= -m "not enable_socket"
+}