summaryrefslogtreecommitdiff
path: root/dev-python/pyphen/pyphen-0.9.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/pyphen/pyphen-0.9.4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/pyphen/pyphen-0.9.4.ebuild')
-rw-r--r--dev-python/pyphen/pyphen-0.9.4.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/pyphen/pyphen-0.9.4.ebuild b/dev-python/pyphen/pyphen-0.9.4.ebuild
new file mode 100644
index 000000000000..9edcfbd4d314
--- /dev/null
+++ b/dev-python/pyphen/pyphen-0.9.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for hyphenation using hunspell dictionaries"
+MY_PN="Pyphen"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+HOMEPAGE="https://github.com/Kozea/Pyphen"
+
+LICENSE="GPL-2+ LGPL-2+ MPL-1.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"