summaryrefslogtreecommitdiff
path: root/dev-python/pypillowfight
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-29 02:06:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-29 02:06:03 +0000
commit2a3c08f4647671d17f534a5dbd8bd45e11c90ea2 (patch)
tree67ecd2d13b251a03c4834bdec638d301818901eb /dev-python/pypillowfight
parenta2148b9fab4c83209816a49f091d70873b19881d (diff)
gentoo auto-resync : 29:11:2024 - 02:06:03
Diffstat (limited to 'dev-python/pypillowfight')
-rw-r--r--dev-python/pypillowfight/Manifest2
-rw-r--r--dev-python/pypillowfight/pypillowfight-0.3.1.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pypillowfight/Manifest b/dev-python/pypillowfight/Manifest
index a59d9fbf2318..ec689b6eed3b 100644
--- a/dev-python/pypillowfight/Manifest
+++ b/dev-python/pypillowfight/Manifest
@@ -1,3 +1,5 @@
+DIST libpillowfight-0.3.1.tar.bz2 87826393 BLAKE2B 7e6b2c3b6069d0e8bf4eea964d6ce3f90759d6d36b31f73780d928180f613abbd639ec7925dafc90be34adb893dfa2764fa818b41a4da6a557d5f9af4c0fa615 SHA512 7d8893a1b5d55b9cbce877b794e23269f838c5a071a6abc3834ee8af00cd3be8a70cfc49cb06653cfda9d91a798b62970c755408c47749971eb5e085699d06b1
DIST libpillowfight-50d965879eb89fdef9be09d6e934329486ff585d.tar.bz2 87826271 BLAKE2B aa0a9c2800992b671940f0ed0c8d808c5ad870c724fbf0f4dad336d224e6d510b135052f2697a6a1d05bafb9f1969278962c625d5d0ffd997b2548e60b1dec2b SHA512 76b05d49e2ee9fc9dcc2c9342d312841c8d1520d8d2027bd12b6921f85bd92645f698a811ccf7bdeceba64f0b706d5fd2975f91c51db8ce87f1261793aee83cb
EBUILD pypillowfight-0.3.0_p20210816-r1.ebuild 1011 BLAKE2B 3bfb6bce04ad7dedb2db614059030aa96a0be8634c0bfd0907f572f57a9a9fb715ebdce3624fd22caa01d02659270c189faf5d81ccf8ae2ec23ed2cf19f6f634 SHA512 3d3727cb8a674fb20e5be328a633cf7ae22748aaff889b10eeb2e0af91b8b360a8571692915c963940e5dc0124ff3fd511a87e403cefb2cf40e531b18b4e5eea
+EBUILD pypillowfight-0.3.1.ebuild 953 BLAKE2B fe28a09408aa1d9616062c2e7c89f225cedb17145cc3089e543855241ed4453d94bb179ee873fd1bf84def2d2a8021e5e583131777ee6ee15e8d08e6abc96fa8 SHA512 e00fab2b0389fc82eb1ab2dde6dcc4043b32e2d4cba2a07110bc48e40abb0fbaa84fd450737d167c42ec4f094e745f73c20643183590509b087d442caa57a87e
MISC metadata.xml 421 BLAKE2B af873a75bfc94519921eb02333aab53d0c0a4b15ef2951fbe721519650a864e82807296eede3dd566395860cc1c9ba60cdf6768083368b717a7e2a8d7052b192 SHA512 cc9b04007e18bf0cbbcdb3fe0c9c75cf0c32afaed192cca98fedd6a6f135422794db2758f5f23f4870900d22b124a6cbc315dd51a1137c874d2c6461766c009f
diff --git a/dev-python/pypillowfight/pypillowfight-0.3.1.ebuild b/dev-python/pypillowfight/pypillowfight-0.3.1.ebuild
new file mode 100644
index 000000000000..8e1c11905150
--- /dev/null
+++ b/dev-python/pypillowfight/pypillowfight-0.3.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+MY_P=libpillowfight-${PV}
+DESCRIPTION="Small library containing various image processing algorithms"
+HOMEPAGE="
+ https://gitlab.gnome.org/World/OpenPaperwork/libpillowfight/
+ https://pypi.org/project/pypillowfight/
+"
+SRC_URI="
+ https://gitlab.gnome.org/World/OpenPaperwork/libpillowfight/-/archive/${PV}/${MY_P}.tar.bz2
+"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/pillow[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e "/'nose>=1.0'/d" -i setup.py || die
+ cat > src/pillowfight/_version.h <<- EOF || die
+ #define INTERNAL_PILLOWFIGHT_VERSION "$(ver_cut 1-3)"
+ EOF
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests -o addopts=
+}