summaryrefslogtreecommitdiff
path: root/dev-python/pyproject-api/pyproject-api-1.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-06 09:09:23 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-06 09:09:23 +0000
commit1fe7aef6facf013a94eac853717f4da4d5d3c5b3 (patch)
tree78504cbc51fdbf8ae4827c383f075559cf162fa8 /dev-python/pyproject-api/pyproject-api-1.2.1.ebuild
parent7bf9e3db263e64d6cbc306440a7f3c44e551bb13 (diff)
gentoo auto-resync : 06:12:2022 - 09:09:23
Diffstat (limited to 'dev-python/pyproject-api/pyproject-api-1.2.1.ebuild')
-rw-r--r--dev-python/pyproject-api/pyproject-api-1.2.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pyproject-api/pyproject-api-1.2.1.ebuild b/dev-python/pyproject-api/pyproject-api-1.2.1.ebuild
new file mode 100644
index 000000000000..befb99d14d42
--- /dev/null
+++ b/dev-python/pyproject-api/pyproject-api-1.2.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="API to interact with the python pyproject.toml based projects"
+HOMEPAGE="
+ https://github.com/tox-dev/pyproject-api/
+ https://pypi.org/project/pyproject-api/
+"
+SRC_URI="
+ https://github.com/tox-dev/pyproject-api/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10)
+"
+BDEPEND="
+ >=dev-python/hatch-vcs-0.2[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/pytest-mock-3.10[${PYTHON_USEDEP}]
+ >=dev-python/wheel-0.37.1[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20.17[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}