summaryrefslogtreecommitdiff
path: root/dev-python/pyproject-fmt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-02 22:51:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-02 22:51:20 +0100
commit1e9c38efad2f42ea208e40924d1e5936810ac7c0 (patch)
treedbcaa52c820c84eaba974e8a5bf4ba2b05a4bed2 /dev-python/pyproject-fmt
parent1f6d51a43dbfcb87ef81da70c688d354560e846a (diff)
gentoo auto-resync : 02:08:2023 - 22:51:19
Diffstat (limited to 'dev-python/pyproject-fmt')
-rw-r--r--dev-python/pyproject-fmt/Manifest1
-rw-r--r--dev-python/pyproject-fmt/pyproject-fmt-0.13.0-r1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pyproject-fmt/Manifest b/dev-python/pyproject-fmt/Manifest
index 4595de82b348..a233628e7f84 100644
--- a/dev-python/pyproject-fmt/Manifest
+++ b/dev-python/pyproject-fmt/Manifest
@@ -5,5 +5,6 @@ DIST pyproject_fmt-0.13.0.tar.gz 13021 BLAKE2B 911925fb489782af9952cea68105ceeaa
EBUILD pyproject-fmt-0.11.2.ebuild 775 BLAKE2B f9b4f138b36c1d48afaaa242313cf95d4dbec1c1a23ec988697adeaa3efaa6d666ffe4210acedd5db82865033b526ff139f4084f59fd7c1c257a0725884b3ee8 SHA512 3d402ddf5f98337dae17b66341f5affa6e95d3167a469c2767e9006e3f96ec8a84adcbf27d8f9f1bbdfe89dd415315423b5f01a9c93024683affeb84ad725a6e
EBUILD pyproject-fmt-0.12.0.ebuild 783 BLAKE2B 9305fc4f3a93653b8a5ee516452ecfd712bbd710818cef177a96f35ca793ebf560cf809d3b7b9cf99f2e269798601191dbec61c0416be25955250c4777a9f860 SHA512 acc912914d40cb67b7b08dd92128b497e91709eaf3f55488a83cd9428be0cd2ffc18f22bdb9d8c04bf26b04c9f9c1d096af123fb96617a34b2f9a08695b2a4b3
EBUILD pyproject-fmt-0.12.1.ebuild 783 BLAKE2B 9305fc4f3a93653b8a5ee516452ecfd712bbd710818cef177a96f35ca793ebf560cf809d3b7b9cf99f2e269798601191dbec61c0416be25955250c4777a9f860 SHA512 acc912914d40cb67b7b08dd92128b497e91709eaf3f55488a83cd9428be0cd2ffc18f22bdb9d8c04bf26b04c9f9c1d096af123fb96617a34b2f9a08695b2a4b3
+EBUILD pyproject-fmt-0.13.0-r1.ebuild 854 BLAKE2B 5f7ad3778b4a1d184f3b487e08fee8c8a69f5d15c945af762677d344043b0ca6bdafab293333f1422a8a9ade9287ba9af5f311c08c98d656b15477d763b2e189 SHA512 cab819617e5b112c963eaaeb9754244ca56d6a960d8e6f23ab08be0e1a62bf19aaa5dab5f6649135d72ada49d17071505cb56a01936312e1f6bc833c1e604dba
EBUILD pyproject-fmt-0.13.0.ebuild 783 BLAKE2B 9305fc4f3a93653b8a5ee516452ecfd712bbd710818cef177a96f35ca793ebf560cf809d3b7b9cf99f2e269798601191dbec61c0416be25955250c4777a9f860 SHA512 acc912914d40cb67b7b08dd92128b497e91709eaf3f55488a83cd9428be0cd2ffc18f22bdb9d8c04bf26b04c9f9c1d096af123fb96617a34b2f9a08695b2a4b3
MISC metadata.xml 380 BLAKE2B f139b3f6c22d40d7c91b9b35db262813e299d1a3c1a1f8d6129e457fac62e3e7029a05315a3bddd9c4542764a33160c89b58b3b62f457efb088a7ae7cd86a936 SHA512 38bd0633defb67ee1831480c8b3896e158d0735ec74057b13b3c389cf26bd6ecb878f21d172f83293789d81ca2c30afedab8eaeb4ab1774b39972fdd5f805a81
diff --git a/dev-python/pyproject-fmt/pyproject-fmt-0.13.0-r1.ebuild b/dev-python/pyproject-fmt/pyproject-fmt-0.13.0-r1.ebuild
new file mode 100644
index 000000000000..f5be7a8828e6
--- /dev/null
+++ b/dev-python/pyproject-fmt/pyproject-fmt-0.13.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Format your pyproject.toml file"
+HOMEPAGE="
+ https://github.com/tox-dev/pyproject-fmt/
+ https://pypi.org/project/pyproject-fmt/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/natsort-8.3.1[${PYTHON_USEDEP}]
+ >=dev-python/packaging-23.1[${PYTHON_USEDEP}]
+ >=dev-python/tomlkit-0.11.8[${PYTHON_USEDEP}]
+"
+# tox is called as a subprocess, to get targets from tox.ini
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/pytest-mock-3.10[${PYTHON_USEDEP}]
+ dev-python/tox
+ )
+"
+
+distutils_enable_tests pytest