summaryrefslogtreecommitdiff
path: root/dev-python/pyqtgraph
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-14 02:02:08 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-14 02:02:08 +0000
commit59d772d9463f8cf6a145a677bedbf377a0625aff (patch)
tree5a0e382968fd656a056c886e36cfb4491535b489 /dev-python/pyqtgraph
parent2a3e0d61b3d88306b6fae46756f9ba7d230222ae (diff)
gentoo auto-resync : 14:12:2024 - 02:02:07
Diffstat (limited to 'dev-python/pyqtgraph')
-rw-r--r--dev-python/pyqtgraph/Manifest2
-rw-r--r--dev-python/pyqtgraph/pyqtgraph-0.13.7-r2.ebuild20
2 files changed, 6 insertions, 16 deletions
diff --git a/dev-python/pyqtgraph/Manifest b/dev-python/pyqtgraph/Manifest
index 423402b3f2fa..020504d65c66 100644
--- a/dev-python/pyqtgraph/Manifest
+++ b/dev-python/pyqtgraph/Manifest
@@ -1,3 +1,3 @@
DIST pyqtgraph-0.13.7.gh.tar.gz 2364456 BLAKE2B 3ce1a3eb177a2a6328f1b7354bf9d4a87ffedcf4fa75fa407bd2df708b91fe98e2500364220ac7395745c69ac86f4830ea58999d05af49850edc723a6ccad5a1 SHA512 91e06e143fec4b1a6fae5cc7112a1fb6b7e74c7a38605172aacc5639eb220e30c54694e419313c7bb8368ea5c5f45f41d58e4510735e63a7d6ef03cdbb0f05e9
-EBUILD pyqtgraph-0.13.7-r2.ebuild 4654 BLAKE2B d00360cedf1b3b77300b64b449a7d4daa215639b057a0cc1629c7a0b5c4b8cd9e53cee215c28512d672b1d5361c037751782b7084e84842849095f8b1843eca3 SHA512 1d017e83ba18cb82a1fe93c65ec839d2ae0798b2c4567c18beb1fe647e667aa80734a22a84b90a93a345a29052e5e3fea85a15a0d96719814a6b985110948416
+EBUILD pyqtgraph-0.13.7-r2.ebuild 4245 BLAKE2B a5dc6ccfd4854491de7b11f03433454e047794159279c13fa157e95460d0778f02d1bb6bcd0a80f6aa7fc37a684ccadb9c86634c662f5ecb1e31e48ed13e6df9 SHA512 3350de940d2a594d9f8063d4e4445265e18a7ce296402cab9b4bf80bd0d57013ea1a3cb6a3c59791c96990b9c5c54bf4133cb55f1d192fc9e1fd9cfa851be525
MISC metadata.xml 774 BLAKE2B b3e5e1017a2814db18f9b22de58f1b52feb0ec106259808e384bc45565f0a192bd73fe9cfb91d5e08aff0400e493ef0a70ae289de5d46185d99c42111bc80274 SHA512 c4eb8ac45b5c9b3450fba9aa7b84d3a48991c2d8e00b20d6f953a1ac6f54a818aa0c9d8c31a0cbf558bf453c02e3a21df7f472a81bb1d6188209c9e26de5526c
diff --git a/dev-python/pyqtgraph/pyqtgraph-0.13.7-r2.ebuild b/dev-python/pyqtgraph/pyqtgraph-0.13.7-r2.ebuild
index a8489dd42e82..da88a6aa8310 100644
--- a/dev-python/pyqtgraph/pyqtgraph-0.13.7-r2.ebuild
+++ b/dev-python/pyqtgraph/pyqtgraph-0.13.7-r2.ebuild
@@ -41,6 +41,7 @@ BDEPEND="
dev-python/pytest-xvfb[${PYTHON_USEDEP}]
dev-vcs/git
)
+ sys-apps/gawk
"
EPYTEST_XDIST=1
@@ -83,7 +84,7 @@ python_prepare_all() {
fi
done
- awk -v qt_string="$(printf "%s\n" "${gentoo_qt[@]}")" -i inplace '
+ gawk -v qt_string="$(printf "%s\n" "${gentoo_qt[@]}")" -i inplace '
BEGIN {
i = 0
split(qt_string, qt_array, "\n")
@@ -109,15 +110,11 @@ python_prepare_all() {
# The order is important (we want to prefer the newest at runtime)
for qt in qt6 qt5; do
if use ${qt}; then
- if [[ "${qt}" == qt* ]]; then
- liborder+=( "PY${qt^^}" )
- else
- liborder+=( "${qt^^}" )
- fi
+ liborder+=( "PY${qt^^}" )
fi
done
- awk -v libOrder="$(printf "%s, " "${liborder[@]}")" -i inplace '
+ gawk -v libOrder="$(printf "%s, " "${liborder[@]}")" -i inplace '
BEGIN {
libOrder = "[" substr(libOrder, 1, length(libOrder) - 2) "]"
}
@@ -135,7 +132,7 @@ python_prepare_all() {
frontends+=( "Qt.PY${qt^^}: False," )
fi
done
- awk -v frontends="$(printf "%s\n" "${frontends[@]}")" -i inplace '
+ gawk -v frontends="$(printf "%s\n" "${frontends[@]}")" -i inplace '
BEGIN {
i = 0
split(frontends, frontend_array, "\n")
@@ -167,13 +164,6 @@ python_test() {
# TODO
tests/exporters/test_svg.py::test_plotscene
tests/graphicsItems/test_ROI.py::test_PolyLineROI
-
- # pyside2 is normally skipped if not installed but these two
- # fail if it is installed
- # TODO: this could be due to USE flags, revisit when pyside2
- # gains py3.9
- 'pyqtgraph/examples/test_examples.py::testExamples[ DateAxisItem_QtDesigner.py - PySide2 ]'
- 'pyqtgraph/examples/test_examples.py::testExamples[ designerExample.py - PySide2 ]'
)
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1