summaryrefslogtreecommitdiff
path: root/dev-python/pyrax
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pyrax
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pyrax')
-rw-r--r--dev-python/pyrax/Manifest3
-rw-r--r--dev-python/pyrax/metadata.xml21
-rw-r--r--dev-python/pyrax/pyrax-1.9.7.ebuild44
3 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/pyrax/Manifest b/dev-python/pyrax/Manifest
new file mode 100644
index 000000000000..f6757edc1a11
--- /dev/null
+++ b/dev-python/pyrax/Manifest
@@ -0,0 +1,3 @@
+DIST pyrax-1.9.7.tar.gz 313170 BLAKE2B b52d87f22f546d095ce7ddd6d83559d14b432e0e910839c33b54572e3e78ec1d7f1077bdcf87fad62f695948864e6445b3a1e4635d2ec9b09973fd66b3e32dc4 SHA512 e83c5e79d49eb3095e8e196b4c9db419194131503d95737564e5a1e3e20f06aa4b53196111d8d326ac50041cd0c2590cefeb41d7d6d654112a85df867b7495f3
+EBUILD pyrax-1.9.7.ebuild 1076 BLAKE2B a7d049e5405ef983ba05f6988a8556eddb9c8503d2399feb67d2c6e9f184dda2cc50285c95a8087c3359cb1f3cf6a7d275f50d903ef6dbd3f6b558253811f5dc SHA512 dac80fb4d86a79e6a8907dde2c2aa8d02765647ad77d4f547e3c384ce968e47ffde1bc73f9287a430d0284bb089846034773cbe4239f4245daa9286a5b0b9231
+MISC metadata.xml 695 BLAKE2B ad76557a077263a066097827d9ac06581a6fcabb034852ba237815fa79deddfb248ec8522164ba2e1b62b09b829c2416837021177307c9b4516aed482c661bdf SHA512 b396d429fc52efdfaa1fd0773d336ead34bc18cf3f03e7d9813090a5cc0dc395f3e605b409d6439d529c90c0ccf45e524bfcca99e550a40138bb278cfca29092
diff --git a/dev-python/pyrax/metadata.xml b/dev-python/pyrax/metadata.xml
new file mode 100644
index 000000000000..36c8d0c095f2
--- /dev/null
+++ b/dev-python/pyrax/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ Python SDK for OpenStack/Rackspace APIs
+ pyrax should work with most OpenStack-based cloud deployments,
+ though it specifically targets the Rackspace public cloud.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">pyrax</remote-id>
+ <remote-id type="github">rackspace/pyrax</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyrax/pyrax-1.9.7.ebuild b/dev-python/pyrax/pyrax-1.9.7.ebuild
new file mode 100644
index 000000000000..364b110b6959
--- /dev/null
+++ b/dev-python/pyrax/pyrax-1.9.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python language bindings for OpenStack Clouds"
+HOMEPAGE="https://github.com/rackspace/pyrax"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+CDEPEND="
+ dev-python/keyring[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/python-novaclient-2.13.0[${PYTHON_USEDEP}]
+ dev-python/rackspace-novaclient[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.2.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${CDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/rax-scheduled-images-python-novaclient-ext[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_test() {
+ nosetests tests/unit || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( samples/. )
+
+ distutils-r1_python_install_all
+}