summaryrefslogtreecommitdiff
path: root/dev-python/pyrqlite/pyrqlite-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/pyrqlite/pyrqlite-9999.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/pyrqlite/pyrqlite-9999.ebuild')
-rw-r--r--dev-python/pyrqlite/pyrqlite-9999.ebuild14
1 files changed, 1 insertions, 13 deletions
diff --git a/dev-python/pyrqlite/pyrqlite-9999.ebuild b/dev-python/pyrqlite/pyrqlite-9999.ebuild
index 342b0c8e9e27..4ad296a7f2cd 100644
--- a/dev-python/pyrqlite/pyrqlite-9999.ebuild
+++ b/dev-python/pyrqlite/pyrqlite-9999.ebuild
@@ -17,22 +17,10 @@ HOMEPAGE="https://github.com/rqlite/pyrqlite"
LICENSE="MIT"
SLOT="0"
KEYWORDS=""
-IUSE="test"
-RESTRICT="!test? ( test )"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- dev-python/pylint[${PYTHON_USEDEP}]
- )"
+distutils_enable_tests pytest
src_prepare() {
sed -e "s:^__version__ = .*:__version__ = '${PV}':" -i src/${PN}/constants.py || die
distutils-r1_src_prepare
}
-
-python_test() {
- esetup.py test || die "tests failed"
- esetup.py lint -f text -E || die "pylint failed"
-}