summaryrefslogtreecommitdiff
path: root/dev-python/pyrsistent/pyrsistent-0.19.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-31 21:06:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-10-31 21:06:00 +0000
commitc9c609463fab9bcfb35694627bca1429a21fdbb2 (patch)
tree024860c3c54aa33cdb6972acd3e2e0b8484f3aa7 /dev-python/pyrsistent/pyrsistent-0.19.1.ebuild
parent6dd9db91dd6ce9bbe3197aa82642866e637ba68d (diff)
gentoo auto-resync : 31:10:2022 - 21:05:59
Diffstat (limited to 'dev-python/pyrsistent/pyrsistent-0.19.1.ebuild')
-rw-r--r--dev-python/pyrsistent/pyrsistent-0.19.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pyrsistent/pyrsistent-0.19.1.ebuild b/dev-python/pyrsistent/pyrsistent-0.19.1.ebuild
new file mode 100644
index 000000000000..7a4e9ef1fc6d
--- /dev/null
+++ b/dev-python/pyrsistent/pyrsistent-0.19.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Persistent/Functional/Immutable data structures"
+HOMEPAGE="
+ https://github.com/tobgu/pyrsistent/
+ https://pypi.org/project/pyrsistent/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest