summaryrefslogtreecommitdiff
path: root/dev-python/pyscard
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /dev-python/pyscard
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'dev-python/pyscard')
-rw-r--r--dev-python/pyscard/Manifest4
-rw-r--r--dev-python/pyscard/pyscard-1.9.7.ebuild2
-rw-r--r--dev-python/pyscard/pyscard-1.9.9.ebuild34
3 files changed, 38 insertions, 2 deletions
diff --git a/dev-python/pyscard/Manifest b/dev-python/pyscard/Manifest
index 7ea6a237e902..7d54d19695f0 100644
--- a/dev-python/pyscard/Manifest
+++ b/dev-python/pyscard/Manifest
@@ -1,3 +1,5 @@
DIST pyscard-1.9.7.tar.gz 144692 BLAKE2B 5a842b790e01ff5461c462d6fe2d7763a79725cd1bcb841c1aaa49f2b17decb251446adb908fa8b525b91f418a6df6a76ddf779a67b7e8547211993837aed2bd SHA512 339d6efd5fcaa361e30029e736d4e2e98e05acd701c39574b40960b4bcec4782ca9c1d6927cea0b3641c5e6a137d0b9fbd961b58422a4151cfbdfa067dcd4b4a
-EBUILD pyscard-1.9.7.ebuild 753 BLAKE2B ba853b738687844abac8dfed836ba27b49b3d186a8f62c9c242c8add0b7d73ff5f9144e831b70a1337e93739cf2d96ddfb935b8843ccc9ac8cefa967904c80e3 SHA512 61d3dc6fd3d0b69c5e57414c920cd238c2587fc0266f6d92ee3c4bef30c40b787ad0794854b0edd09e54a27bcece594040f7143f15929624a8c21328d1c21217
+DIST pyscard-1.9.9.tar.gz 145428 BLAKE2B c62d9c2f13d9f19df1b7399509efc9df2baf2da00a9dc0bd9a0b440dcef232beeb0f7da88b12e3fb8ecffeb28f268eaaa04c9d45dc3420a1071835afe7a36c95 SHA512 88c7314c10153f509eb9bf6318e62210c7182e51b531af752a402bf8d05cfa2658cc1a4e7b9385a474038ddfa5a1bfbf1f208fcd9abe02a60161ce7c757c67b2
+EBUILD pyscard-1.9.7.ebuild 759 BLAKE2B 11205877ee1c742cc804ee4eef46f9ba54906b1524137bfb0fb0276a59cb51945b773327f7806e0eb9609308a4b69988c1f94e069a59babc1ff2354a782f469a SHA512 c317d6aaae96b995c0a0e397dd139482b3f233b309e0817280b8eee2454786c4fef1eccb4337590af4c750f2b3831456c3bca1b7f1eb63d1689ff474a435a41e
+EBUILD pyscard-1.9.9.ebuild 761 BLAKE2B cb355313dfcea1820486f11b75c0902b755767220fe980079fdc6f32ebdd391cf82ae12e834b79b045d3dfb67403fc7d19fe84cb85ad5bb72df5ea88e48d5f90 SHA512 fbcebb9f9cafcf31734567ff064188e08bab79eabcb12c57e601ae8c89a48a930b1957a924ddc87a41137f376b0f83b34632788df2d288852ffa181cae7ddd80
MISC metadata.xml 317 BLAKE2B f87dee8af30517c70bf141fe7da6a953f61f894e7f97897f3c2a594fae16212a518e80eb2141e2ae18da562a91a85ca74209e0c77f4b9bc54e91fe9bd02f650c SHA512 f0ee67c282ef764df07b1f49ea3fa4714ecc6094046aa6fb986274968e58801eb3f7a32463bf4282dfb607202b2b4e5e1b50a0d54f79e85f64a6abb2d68e309e
diff --git a/dev-python/pyscard/pyscard-1.9.7.ebuild b/dev-python/pyscard/pyscard-1.9.7.ebuild
index 37623d99e50c..9321e8fa39a1 100644
--- a/dev-python/pyscard/pyscard-1.9.7.ebuild
+++ b/dev-python/pyscard/pyscard-1.9.7.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit distutils-r1 eutils
diff --git a/dev-python/pyscard/pyscard-1.9.9.ebuild b/dev-python/pyscard/pyscard-1.9.9.ebuild
new file mode 100644
index 000000000000..5c90cee6a2f5
--- /dev/null
+++ b/dev-python/pyscard/pyscard-1.9.9.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Smart cards support in python"
+HOMEPAGE="https://pyscard.sourceforge.io/
+ https://github.com/LudovicRousseau/pyscard
+ https://pypi.org/project/pyscard/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="${PYTHON_DEP}
+ sys-apps/pcsc-lite"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+BDEPEND="${PYTHON_DEP}
+ dev-lang/swig"
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ optfeature "Gui support" dev-python/wxpython
+ optfeature "Support of remote readers with Pyro" dev-python/pyro
+}