summaryrefslogtreecommitdiff
path: root/dev-python/pysendfile
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/pysendfile
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/pysendfile')
-rw-r--r--dev-python/pysendfile/Manifest5
-rw-r--r--dev-python/pysendfile/metadata.xml12
-rw-r--r--dev-python/pysendfile/pysendfile-2.0.1.ebuild21
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pysendfile/Manifest b/dev-python/pysendfile/Manifest
new file mode 100644
index 000000000000..40e1a234a0eb
--- /dev/null
+++ b/dev-python/pysendfile/Manifest
@@ -0,0 +1,5 @@
+DIST pysendfile-2.0.1.tar.gz 19315 SHA256 510a414b270986fba3c79cb76d90a4c910c701bfb43ff983a5d4e92846050e17 SHA512 d6ee08eb251fac30c90a9ee829fd992f3620697eef2893ced5a2c6273486c3c5fd35c70962585a8d747d578817391f91c929bfeeba8c4485d52a15748229ca9c WHIRLPOOL a1f9a54ff2f0111d3c62f3ec17490241270d711b8529b701d27b12f7aa607c13c86ae7e2910770b8626b86909c9943e3ab8395676c5c09eff52274165ab64641
+EBUILD pysendfile-2.0.1.ebuild 536 SHA256 5074b0a5ed3c8dc35c7fa0709ecde8efe7be17db3d2c214fe03bf39d905107fe SHA512 0c67160e870a01fe75a061330379ff978d2e0baabe075dbaa68e9fd5cb2d344910ca52b8354dea21a2c8e5ac6e6eef7fdde3b35d6c0c3e3aa45148e5cb16500b WHIRLPOOL b650b8a17ad9401d77d8ebf8f9f9f9a28f9e6106f22e53392550af8f64f615e4350139a4c7342336ac4511bb117d05e0ab73bb944557350bb3ccc3dec4fe6f40
+MISC ChangeLog 3043 SHA256 455849ae4a6f38fc3d9c4779e8885ad4fb843a22fb2740db08ff4e1c0ed15416 SHA512 8cb5574c307ac917a9a7ffcc184fa4c218810efba481b2badc4b6c449bd723ad5734483cfbbe775265b1aeda10929021c2a378fead82c7258da18024e5a609e4 WHIRLPOOL eb857d4c0ab747b7f638be40796e1f10528305e2e17da47c04ae8713dce2166b16ab74b66b3fa1bfb24ae6cd084d51c798c31989db12df676a1c3f96d085fc0b
+MISC ChangeLog-2015 1057 SHA256 c81e5b538d241093e1202d06da166790e4571c61f45692713c5c3a7617b4ceb6 SHA512 8b15fcd7d8b7a954505846f7e4f2038aedd2c02d395fa64017a12d79c452ade50e34e136581650d1ed15b741086840c2d435b6ea108a9fc747d1562e44543cf0 WHIRLPOOL e7612ee3a6b48b1efe9806e9a745a0920a2265810314bf5b01ed5fb57c6f5af0cbd94bd5aa186de6f57041a3910a3c2332e198629a240cdb23e4bd5f4aa147a0
+MISC metadata.xml 391 SHA256 8025ed90ff1400982926e6c29e54df9e0e22f10ad1e6d422d898c2dde6e056ad SHA512 9f2f7252b4d4f062d63fd392634973c0ad3febc22375631afd41f53f45bce5ae9dd0350f926576bb18883b91f9d5de60881fca77d444703fcfbb706c7802067c WHIRLPOOL 3c5f7e1db0238828a1b0556b41ff28fe517462609504290ef873f1a7abe77a53db388faed40e8b9b1fddc3d64421cbbc458ce6c75e29565e6e7a9124ec6eef50
diff --git a/dev-python/pysendfile/metadata.xml b/dev-python/pysendfile/metadata.xml
new file mode 100644
index 000000000000..95cca6de01c5
--- /dev/null
+++ b/dev-python/pysendfile/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>openstack@gentoo.org</email>
+ <name>Openstack</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pysendfile</remote-id>
+ <remote-id type="github">giampaolo/pysendfile</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pysendfile/pysendfile-2.0.1.ebuild b/dev-python/pysendfile/pysendfile-2.0.1.ebuild
new file mode 100644
index 000000000000..dce56df30bdc
--- /dev/null
+++ b/dev-python/pysendfile/pysendfile-2.0.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A python interface to sendfile(2) system call"
+HOMEPAGE="https://github.com/giampaolo/pysendfile"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="amd64 x86"
+IUSE=""
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# Testsuite abandonned due to demanding starting a local web type server