summaryrefslogtreecommitdiff
path: root/dev-python/pysha3
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-20 17:35:36 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-20 17:35:36 +0100
commitb620fb1b0929ff9657a2588aaa42b85e3021c102 (patch)
tree5c4e9e39b5d3ea7fc569c26b0d4ba6db582249e6 /dev-python/pysha3
parentd473a706836012853193afc7000922601e4ada61 (diff)
gentoo resync : 20.10.2017
Diffstat (limited to 'dev-python/pysha3')
-rw-r--r--dev-python/pysha3/Manifest3
-rw-r--r--dev-python/pysha3/metadata.xml15
-rw-r--r--dev-python/pysha3/pysha3-1.0.2.ebuild22
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pysha3/Manifest b/dev-python/pysha3/Manifest
new file mode 100644
index 000000000000..a15b9efaaccf
--- /dev/null
+++ b/dev-python/pysha3/Manifest
@@ -0,0 +1,3 @@
+DIST pysha3-1.0.2.tar.gz 829192 SHA256 fe988e73f2ce6d947220624f04d467faf05f1bbdbc64b0a201296bb3af92739e SHA512 57476d24b9d399471cf56c8c1413f58dbc863c16d4fe9ebd2cf65df8092e139e2505252605e3fccd68978f5ee3fffdfeeedee6788aab38a54c918a452fc19720 WHIRLPOOL 0de14913b4c02b1c8310432f6a71ed986c6f525c7b15bb6e91d3972a84f5599b13d621b04a4007ea276089cd75d965798a84b11d378e02ab50e1b6d243b62bc0
+EBUILD pysha3-1.0.2.ebuild 506 SHA256 e601d4866d605ba991e30cfe5004f443b2173e3860b9e61e5e2a74ec2a67ee03 SHA512 fd76313141ec0ea1f121adfdcfe56a5f1560dbd35f797a63323516d6d4e24702aa0e06dc270f841df607464650d16a32fd36a214db2dc21dd9369956b5608000 WHIRLPOOL 2eed6e1b11a98b5bd69fc6c2ef991906d195cf49d87e15abc19a27551cce1f4a6758c117c2c6e0703499c9abaec5375eca789fc799d79d389b2ddaabaf4ab9cf
+MISC metadata.xml 447 SHA256 20e1d0abd801718c6a7145bbc1f8bfe93ba10ec12c367ce2aa50830655f9f93e SHA512 e29bf7eb65b03e9190be49df6e924da2e8a6d30eb74bad5cd5b3551df5184c720c9666a11c0cf4afe4626a3d433edd0989507583d97aa24cf5b8bb9ffb535b9d WHIRLPOOL 56a1d3524f24596aab3bf5f1fdddbf48a59c33e2532eeda65f14971d5da1ae2c026f3ddc08bd07a39d24c09684ab69c2a8b61d2f5c67d363cbdb6afed39bc199
diff --git a/dev-python/pysha3/metadata.xml b/dev-python/pysha3/metadata.xml
new file mode 100644
index 000000000000..410617d33dce
--- /dev/null
+++ b/dev-python/pysha3/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tiran/pysha3</remote-id>
+ <remote-id type="pypi">pysha3</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pysha3/pysha3-1.0.2.ebuild b/dev-python/pysha3/pysha3-1.0.2.ebuild
new file mode 100644
index 000000000000..2f9172ea7855
--- /dev/null
+++ b/dev-python/pysha3/pysha3-1.0.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+inherit distutils-r1
+
+DESCRIPTION="SHA-3 (Keccak) for Python 2.7 - 3.5"
+HOMEPAGE="https://github.com/tiran/pysha3 https://pypi.python.org/pypi/pysha3"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="CC0-1.0 PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}