summaryrefslogtreecommitdiff
path: root/dev-python/pyshark
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/pyshark
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/pyshark')
-rw-r--r--dev-python/pyshark/Manifest5
-rw-r--r--dev-python/pyshark/metadata.xml12
-rw-r--r--dev-python/pyshark/pyshark-0.3.7.2.ebuild49
3 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/pyshark/Manifest b/dev-python/pyshark/Manifest
new file mode 100644
index 000000000000..642adcec9a1f
--- /dev/null
+++ b/dev-python/pyshark/Manifest
@@ -0,0 +1,5 @@
+DIST pyshark-0.3.7.2.tar.gz 27232 SHA256 a60bee95e5359c11f2051ebbb240c41becfa8c1ffe03b2fb24895f477bb1c0fe SHA512 dbd97665fae7d3067582bf7616e025b0c5e5fa14cacdaca59c89b4e70feb3017f2d8c7d899a70c0c8707589e4735b9283914bb6ccbf432e9072c64d7e957bc15 WHIRLPOOL 9e6f58dc6a4e2acf77f016b35583da427ccfc8ed32d508e3e7b754913f9e8f6dce2c48be5adf1c2fa56fabecd99f18e1a678dace1c1423be132bcbdbbb85effd
+EBUILD pyshark-0.3.7.2.ebuild 1258 SHA256 0145641e3294c5279ed2f14bc0b110d6a597907d3d9ff6bd7fcb4915802d0d3a SHA512 77c4737ed931f8f0c7f19aa231c7e68e231756c54f6aa6c0ac97502a0c04a1c22affd00cb0dce4abd2c467961e3be1e7b745a32ca257cb09a128b9285ab4626a WHIRLPOOL b47962ab1f48162c399385d52a70a6ee7d4ca975a900f82e4f440c3cc2e3531aa4327160c340297b9d3797bf24fc9eef363478e89c964bcacbe97bf815713b9e
+MISC ChangeLog 3099 SHA256 cf2bb2f76d18e3301af40855d42c8e08bb94a1f1361e633f6e0725bc6249d3f6 SHA512 5b1581c4f03f16fbe16d09da135291ee23e129c6818a6c60432c330af1254b7f5bfe8147ffa8309cb3ed109f2c66783810ded9f57ee2aed3c9d9f7c9641e9d52 WHIRLPOOL e469a8fbb2968456be6af7ffc2edf39663bb89dc84f540bf17110408ac0cb3700965ed997800bd084b07d65b41d9a2b10fd4f41b45f38c8834240dfa694d73f9
+MISC ChangeLog-2015 901 SHA256 3feddf4854eaf17a5f1661704917985a41b9f53e810e9af4e5663f534b8bcdd8 SHA512 12fd367a08377e83ae1c5dc24bb2af77b4f1b96d070052cfc804373b66722b442dc31929403f9bb7a85aaab67d2891589f6f23e537813b98a6cb2136e3f8a9e6 WHIRLPOOL bd591aed2df677ce3a648d57efad4157204f76f46c2f2c736944b4fbc234fa88dc7d78faa5929d33659de3f5d15b013c152d70482518775e7005a0a9e75d1831
+MISC metadata.xml 378 SHA256 8aa9075f5931308af781c2324f3faf47d89ccd92f14180688bf3d56fd6dccf3e SHA512 17d2661a631633ebf347dfc4def34aa070c4ad5713f6124b668c3ed5336a59b639c30474e4b4cb294661648ef186797144c161a390c0d93a21de82ae8d51d8c7 WHIRLPOOL e3b030a129b13680f182890eb505d955f5484499344471bbeb4e46cf4e064e6c1dc6c953e93527ef261c32733889667178d845f3d48456519eee88c4d9477f48
diff --git a/dev-python/pyshark/metadata.xml b/dev-python/pyshark/metadata.xml
new file mode 100644
index 000000000000..667dc8a5fb8b
--- /dev/null
+++ b/dev-python/pyshark/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pyshark</remote-id>
+ <remote-id type="github">KimiNewt/pyshark</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyshark/pyshark-0.3.7.2.ebuild b/dev-python/pyshark/pyshark-0.3.7.2.ebuild
new file mode 100644
index 000000000000..4d11881ab65e
--- /dev/null
+++ b/dev-python/pyshark/pyshark-0.3.7.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A Python wrapper for tshark output parsing"
+HOMEPAGE="https://pypi.python.org/pypi/pyshark https://github.com/KimiNewt/pyshark"
+# pypi tarball is missing tests
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/KimiNewt/pyshark/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# See pyshark.egg-info/requires.txt
+RDEPEND="
+ dev-python/py[${PYTHON_USEDEP}]
+ dev-python/logbook[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/trollius[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ net-analyzer/wireshark"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${P}/src"
+
+python_prepare_all() {
+ # Test fails unless portage can execute /usr/bin/dumpcap
+ # https://github.com/KimiNewt/pyshark/issues/197
+ rm "${WORKDIR}/${P}/tests/capture/test_inmem_capture.py" || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cd "${WORKDIR}/${P}/tests" || die
+ py.test -v || die
+}