summaryrefslogtreecommitdiff
path: root/dev-python/pyspectrum2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-python/pyspectrum2
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-python/pyspectrum2')
-rw-r--r--dev-python/pyspectrum2/Manifest3
-rw-r--r--dev-python/pyspectrum2/metadata.xml16
-rw-r--r--dev-python/pyspectrum2/pyspectrum2-0.2.0.ebuild26
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pyspectrum2/Manifest b/dev-python/pyspectrum2/Manifest
new file mode 100644
index 000000000000..f578274895d9
--- /dev/null
+++ b/dev-python/pyspectrum2/Manifest
@@ -0,0 +1,3 @@
+DIST pyspectrum2-0.2.0.tar.gz 31500 BLAKE2B 230329f9b1f12c7f7cff234b95d9715609cd0922c6c833726dfe72e7da0ba646e8d059d2f42d70fb97c8cb755436307369336551d44bf7954f2281f49d03ea6f SHA512 40c9f7dda808fd5bca05026b7418022b660d53b6ef52d684885ed04a47185ce2d1e2988bff5b874977c736bf5cf75f10f9daf752475504327844d4f1948f2286
+EBUILD pyspectrum2-0.2.0.ebuild 621 BLAKE2B 9e80421a7ee8bd08ea1e56f6726354c930b915cc77b5e17486ba277b0410fdfd9e09a5f659887dfb69a705d322eae458126421ff6503be5359f8493d70ef8d10 SHA512 5fd53d9d6f119fbf05fce0d6a2e36953787b3a2b762d7a6884d5aa285e7342a28cba1339ee1066fa13377a3a32f39974434437ec0ea22c96d02d1b85ed2f2802
+MISC metadata.xml 560 BLAKE2B fb53cfbb2cf5cf7fcbaeb4c94ac495f838c948c5154c7a22d8e613dc99188ce2a6b4559d9569a5639572cf66ba9df7694112da5d7806dcf656cd5bc8647656c3 SHA512 c3b4e7856ca8d1a178eaff246e75915ca6b73eba78373d91f8c2a1adfe35230a74e0e999a9db723f63cee336b9698b6cd7253db7f63bda72e2ee440e96b74136
diff --git a/dev-python/pyspectrum2/metadata.xml b/dev-python/pyspectrum2/metadata.xml
new file mode 100644
index 000000000000..a7931bdfa4ff
--- /dev/null
+++ b/dev-python/pyspectrum2/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>conikost@gentoo.org</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <longdescription>
+ pyspectrum2 implements the Protobuf-based interface to Spectrum2
+ required for building Python-based Spectrum2 backends.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/stv0g/pyspectrum2/issues</bugs-to>
+ <remote-id type="github">stv0g/pyspectrum2</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyspectrum2/pyspectrum2-0.2.0.ebuild b/dev-python/pyspectrum2/pyspectrum2-0.2.0.ebuild
new file mode 100644
index 000000000000..5e9e84db8831
--- /dev/null
+++ b/dev-python/pyspectrum2/pyspectrum2-0.2.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS="bdepend"
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Implements a protobuf-based interface for Spectrum2 python-based backends"
+HOMEPAGE="https://github.com/stv0g/pyspectrum2"
+SRC_URI="https://github.com/stv0g/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+
+RDEPEND="dev-python/protobuf-python[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ python_optimize
+}