summaryrefslogtreecommitdiff
path: root/dev-python/pyspelling/pyspelling-2.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-19 19:54:34 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-19 19:54:34 +0000
commit3f0a9aff8dc766c410952343d02561aab3eda2b9 (patch)
tree34f459712fafc5ecade61e0db6b3013cb387827c /dev-python/pyspelling/pyspelling-2.9.ebuild
parent00ac4b34406552b4fbca786be59b2983b7f58669 (diff)
gentoo auto-resync : 19:12:2023 - 19:54:34
Diffstat (limited to 'dev-python/pyspelling/pyspelling-2.9.ebuild')
-rw-r--r--dev-python/pyspelling/pyspelling-2.9.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/dev-python/pyspelling/pyspelling-2.9.ebuild b/dev-python/pyspelling/pyspelling-2.9.ebuild
index c541c4c3db44..5cb7f5346224 100644
--- a/dev-python/pyspelling/pyspelling-2.9.ebuild
+++ b/dev-python/pyspelling/pyspelling-2.9.ebuild
@@ -40,9 +40,13 @@ RDEPEND="
>=dev-python/soupsieve-1.8[${PYTHON_USEDEP}]
>=dev-python/wcmatch-6.5[${PYTHON_USEDEP}]
"
-
+# The package can use either aspell or hunspell but tests both if both
+# are installed. Therefore, we need to ensure that both have English
+# dictionary installed.
BDEPEND="
test? (
+ app-dicts/aspell-en
+ app-dicts/myspell-en
dev-vcs/git
)
"
@@ -52,11 +56,11 @@ distutils_enable_tests pytest
python_prepare_all() {
# mkdocs-git-revision-date-localized-plugin needs git repo
if use doc; then
- git init || die
+ git init -q || die
git config --global user.email "you@example.com" || die
git config --global user.name "Your Name" || die
git add . || die
- git commit -m 'init' || die
+ git commit -q -m 'init' || die
fi
distutils-r1_python_prepare_all