summaryrefslogtreecommitdiff
path: root/dev-python/pyspelling
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-03 10:18:28 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-03 10:18:28 +0100
commit015fdd57022ab7a54e47dafe3e81ffc76e502a90 (patch)
tree56dd77e496e4038b74a5c7547be2a320a43ca186 /dev-python/pyspelling
parent778487365a91290a8fd0376883de1a4e874fe27b (diff)
gentoo auto-resync : 03:09:2023 - 10:18:27
Diffstat (limited to 'dev-python/pyspelling')
-rw-r--r--dev-python/pyspelling/Manifest2
-rw-r--r--dev-python/pyspelling/pyspelling-2.9.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/pyspelling/Manifest b/dev-python/pyspelling/Manifest
index 08ff192c15b4..79bb09c568fc 100644
--- a/dev-python/pyspelling/Manifest
+++ b/dev-python/pyspelling/Manifest
@@ -1,3 +1,5 @@
DIST pyspelling-2.8.2.gh.tar.gz 150733 BLAKE2B 1bb96679ce54d48967ee57a7dde00131884e2801a8a4f4e016f9a552b92d435650314ae66a356c90e3e4c585d2701bfc5e63f19b92347c8fada4de64e9a982b6 SHA512 0bb4fbacbc72935d4fb2fa0608d675fd0eec85f178c0994d341bc8635b53f39a4c82a1d50e43446cd39873a877e75b1530eafc36450f37d8f08cc174ba39e440
+DIST pyspelling-2.9.gh.tar.gz 151600 BLAKE2B c706767917e9ba3368f9670a492a2233b6a4c13c4dde6a594a06193d856b3fbad007988acb27486b8b8f62edfeb5a0b030ead3db712baa24b0ff3301cf776937 SHA512 b14d29dff4f7791d9223d20b490f4a48ba5a6a7613dc18fc3083a3b6bf810f9a42fcac94bfe72f92023802fc8c1fe0e6432d491af2f274a138ddc56db5550ea5
EBUILD pyspelling-2.8.2.ebuild 1426 BLAKE2B 293ac3c5e2736e8f461f308933c0b3a23a0947fe972d41a308de04123d0b7583248dbc66a51d622882aaf28b0ab61acbc60f67c5b59b5053e8474e11db1be212 SHA512 55aa8fca955760fabf57725cb95dd8ee47458bacdc53d3ded387586633f33edcf13258411a25448428c395c499c5df36d1328d28adf1c3d0bfcf043022ed343c
+EBUILD pyspelling-2.9.ebuild 1427 BLAKE2B 58e9c9663e864965b6ee1674de887fa338db951b694020888dd59154a4bccd44d3ab6fa2b6e3a4fe5f7906f07c7e60f28349f0e7baa4b7367bb3085c283b6cd1 SHA512 a41be3c283da3be1461d80ed26478cef8a1567b6f04293cfcb9c4e2e341b73a7fc0cd891d091ef33c23360cd589339b63394b1797d3069f3e1fa757515e74790
MISC metadata.xml 2024 BLAKE2B ba187994d3fba90c24276f96371a70a47c652c85ce20d4a11b2a74707e6345b202db00af9771cdc41518267a5a6b0c1ea85d7b68401ff8cb421cfee1fbba98c6 SHA512 53d11553f7e4fbb5057809e0eef8bc33564226bb92c0900f7cc40e8fcbffd20aef04b4635bc2ff2d0c778475fc564a4de02afd1293099710ea81490a435b3f18
diff --git a/dev-python/pyspelling/pyspelling-2.9.ebuild b/dev-python/pyspelling/pyspelling-2.9.ebuild
new file mode 100644
index 000000000000..d491558b8691
--- /dev/null
+++ b/dev-python/pyspelling/pyspelling-2.9.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=hatchling
+
+DOCS_BUILDER="mkdocs"
+DOCS_DEPEND="
+ >=dev-python/mkdocs-pymdownx-material-extras-2.1
+ dev-python/mkdocs-git-revision-date-localized-plugin
+ dev-python/mkdocs-minify-plugin
+"
+
+inherit distutils-r1 docs
+
+DESCRIPTION="Spell checker automation tool"
+HOMEPAGE="
+ https://github.com/facelessuser/pyspelling/
+ https://pypi.org/project/pyspelling/
+"
+SRC_URI="
+ https://github.com/facelessuser/pyspelling/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ || ( app-text/aspell app-text/hunspell )
+
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/soupsieve-1.8[${PYTHON_USEDEP}]
+ >=dev-python/wcmatch-6.5[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # mkdocs-git-revision-date-localized-plugin needs git repo
+ if use doc; then
+ git init || die
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ git add . || die
+ git commit -m 'init' || die
+ fi
+
+ distutils-r1_python_prepare_all
+}