summaryrefslogtreecommitdiff
path: root/dev-python/pyspelling
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-19 14:39:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-19 14:39:08 +0100
commitfc7e841956ae3cc385629bf33433de23a6d04db6 (patch)
tree48882d11ff725a7df862343487d339fdaae1c604 /dev-python/pyspelling
parentdbb637a643576bbb9286907cd6c73e3cda3ca1f6 (diff)
gentoo auto-resync : 19:07:2022 - 14:39:08
Diffstat (limited to 'dev-python/pyspelling')
-rw-r--r--dev-python/pyspelling/Manifest2
-rw-r--r--dev-python/pyspelling/pyspelling-2.8.1.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/pyspelling/Manifest b/dev-python/pyspelling/Manifest
index 309d4736ebc3..1ebea088c41f 100644
--- a/dev-python/pyspelling/Manifest
+++ b/dev-python/pyspelling/Manifest
@@ -1,3 +1,5 @@
DIST pyspelling-2.7.3.tar.gz 151244 BLAKE2B bdfb40c6f39dc5adcc31691ef75b2582e78e8d0ed800ef0e263f8f98987ce3911650cb08085315c617c185e6ef183a11508fde4608349d0dad435b9f4fe1da98 SHA512 6903b620993933e80dfef320c0218c6372ee37f1db958b489d273aca24dd91bcc86fd12967848b8e31c2d7d458fb5fbfb521f41328c5955a1914f7d552ae7341
+DIST pyspelling-2.8.1.gh.tar.gz 150813 BLAKE2B 53df7ae453180007af08fe3928274f9a468f7d24cc5f00b85efbda0febe9532f7b57805b54c2e28c3580e34de383a249bb293b1f89905d2b09c1a70853d12fd3 SHA512 24e9b03b3f5c911e2cd32a5594813fad5fce3fe5cc8c570fdaf4a025aebe8d02d2b77542d6e940cb03350df3203f1a9961a3f446fd60d66250a3cff7c54534de
EBUILD pyspelling-2.7.3.ebuild 1343 BLAKE2B c9c7b5fd242d35b7409437ad367e057d6a9ddd16cd46887e01774fba63c0b3b87447d94cc20ac4e8840f8edfce8b577365d5a9a6596e85e91365b1293adfbd8c SHA512 2c11f06a26a6b07ed3dc1850bde45bdba8ec9fe98408709dceae09ee08944baaf909ff7e0a9165cfe74135966df19515547c585816f17418e00c93f464e9580a
+EBUILD pyspelling-2.8.1.ebuild 1399 BLAKE2B b4f52aa11d6e3747d20ddaff21f341d535c6e2a0889514089198299e218e85c141b340af3dc620bc12d53bca7323e96947e86aa27d796350c0ce5d1b325aa9c2 SHA512 b12f530d5fa91e3c5c5cfdcd81dd0008d076615cfa1df6b751b6ccbf0330215abb9e4772f9c34f4478257aca9c7b595cc4dbd487dc1c3bcb309ca19479fe383c
MISC metadata.xml 2024 BLAKE2B ba187994d3fba90c24276f96371a70a47c652c85ce20d4a11b2a74707e6345b202db00af9771cdc41518267a5a6b0c1ea85d7b68401ff8cb421cfee1fbba98c6 SHA512 53d11553f7e4fbb5057809e0eef8bc33564226bb92c0900f7cc40e8fcbffd20aef04b4635bc2ff2d0c778475fc564a4de02afd1293099710ea81490a435b3f18
diff --git a/dev-python/pyspelling/pyspelling-2.8.1.ebuild b/dev-python/pyspelling/pyspelling-2.8.1.ebuild
new file mode 100644
index 000000000000..f28ee2f060ea
--- /dev/null
+++ b/dev-python/pyspelling/pyspelling-2.8.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=hatchling
+
+DOCS_BUILDER="mkdocs"
+DOCS_DEPEND="
+ >=dev-python/mkdocs_pymdownx_material_extras-2.1
+ dev-python/mkdocs-git-revision-date-localized-plugin
+ dev-python/mkdocs-minify-plugin
+"
+
+inherit distutils-r1 docs
+
+DESCRIPTION="Spell checker automation tool"
+HOMEPAGE="
+ https://github.com/facelessuser/pyspelling/
+ https://pypi.org/project/pyspelling/
+"
+SRC_URI="
+ https://github.com/facelessuser/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ || ( app-text/aspell app-text/hunspell )
+
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/soupsieve-1.8[${PYTHON_USEDEP}]
+ >=dev-python/wcmatch-6.0.3[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # mkdocs-git-revision-date-localized-plugin needs git repo
+ if use doc; then
+ git init || die
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ git add . || die
+ git commit -m 'init' || die
+ fi
+
+ distutils-r1_python_prepare_all
+}