summaryrefslogtreecommitdiff
path: root/dev-python/pyspnego
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-29 10:04:55 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-29 10:04:55 +0100
commit20325cfc3bd40d48d3c7034afaac4f5193d9c704 (patch)
treeb8e6ff7fc02271595e20f956b32cef56c41dafca /dev-python/pyspnego
parent14a6858a7d8bc085420a1430b3a3f67885019f27 (diff)
gentoo auto-resync : 29:08:2023 - 10:04:54
Diffstat (limited to 'dev-python/pyspnego')
-rw-r--r--dev-python/pyspnego/Manifest2
-rw-r--r--dev-python/pyspnego/pyspnego-0.9.2.ebuild39
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pyspnego/Manifest b/dev-python/pyspnego/Manifest
index a64715e5dbe0..74176dfe8cc5 100644
--- a/dev-python/pyspnego/Manifest
+++ b/dev-python/pyspnego/Manifest
@@ -1,3 +1,5 @@
DIST pyspnego-0.9.1.tar.gz 233824 BLAKE2B c36d2ee697ed9dcb7a3c7d3a3ec2bc58b88ac6ba5a020c852b4ba7d0a01d3dd4a3801d91a9456f3f4710684df16a3a4c7d449cfa58e141ae5085bef0f0fe6f21 SHA512 6c516cae43bff523ec19b6ef52e7691a688bada027a183b98e0121bdd4f44f887a5fa87f3ab173dff1e18d84a7886a2a04de80dbd6873cc1dafb1d7369a9d932
+DIST pyspnego-0.9.2.tar.gz 233819 BLAKE2B e4fc4b8cd760210c2e4dd188a651725fa6579fe429ca227e8a5cc1f46111e3e8e6cb07bc4256f60560d86bcd0a2b2e621efbd0dc193d3f67f66a1fdb79ef8f9e SHA512 6775efa12b1f93addf9257145d020e5fcb5139edf8ffcbdca03cd55de7ee992b47af5278206de85e50a824abbf0a037a50dc7e47ca5b6f79b2f4e854d926a8f3
EBUILD pyspnego-0.9.1.ebuild 914 BLAKE2B f23a5faeae4b1c5d6103b1160c59c115d83660a69c1af73326a557b453c43942b3a89711a5c55636c3d1ba8cd0bff8ffa435925510ddfd23502763675089a0ec SHA512 32e6f6e5a43a16c981fc3d2a129619a424ce35b52819a50abbc838a04b5be440834adc5d3663400b3c9018d7adff13b87c51d250e71443510f680d13844ad045
+EBUILD pyspnego-0.9.2.ebuild 917 BLAKE2B 18123ad603638f00f9cc2238b73368a4b3877999e98ea7ec0822e589e3f6c6b3841b2702e892affa337b10f88b24dd8455f3c70ac60419a7dc3419b43b8f67b6 SHA512 dbeab118664219364f95d2e97958731ffeb0428088a7ec0a58870514b42374aab277bf62befaa899aa171b661f8c64e40bc71b1d0534b2bb968f0283880bec57
MISC metadata.xml 445 BLAKE2B 2d30af32987aa7118331cb4c199b44069f6a6efc62d73eab62a31b29308848b7f7e56e026327af6c2197ee31c05fbe1885524bba7b6a84cdc0d97cc58c5fb43b SHA512 c7bbe6f161ce61409f6865f998fb4c8bd77c39011f5bbd148379912e31805773a41451163517cb7ebef99a57d6abe8f13dcdc568408ce182c0def6adf35afc9c
diff --git a/dev-python/pyspnego/pyspnego-0.9.2.ebuild b/dev-python/pyspnego/pyspnego-0.9.2.ebuild
new file mode 100644
index 000000000000..814c28e01ada
--- /dev/null
+++ b/dev-python/pyspnego/pyspnego-0.9.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Library to handle SPNEGO and CredSSP authentication"
+HOMEPAGE="
+ https://github.com/jborean93/pyspnego/
+ https://pypi.org/project/pyspnego/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/gssapi[${PYTHON_USEDEP}]
+ >=dev-python/krb5-0.3.0[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "Kerberos authentication" "dev-python/gssapi >=dev-python/krb5-0.3.0"
+ optfeature "YAML output support" "dev-python/ruamel-yaml"
+}