summaryrefslogtreecommitdiff
path: root/dev-python/pyswisseph
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pyswisseph
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pyswisseph')
-rw-r--r--dev-python/pyswisseph/Manifest5
-rw-r--r--dev-python/pyswisseph/metadata.xml14
-rw-r--r--dev-python/pyswisseph/pyswisseph-2.00.00_p2.ebuild28
-rw-r--r--dev-python/pyswisseph/pyswisseph-2.05.01_pre20160529.ebuild25
4 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/pyswisseph/Manifest b/dev-python/pyswisseph/Manifest
new file mode 100644
index 000000000000..af8fc5ceb853
--- /dev/null
+++ b/dev-python/pyswisseph/Manifest
@@ -0,0 +1,5 @@
+DIST pyswisseph-2.00.00-2.tar.bz2 458443 BLAKE2B 4fa6cfebe46bf0d73bf9f086acf9189a6354762fac604f4dfd3fa6f5d36a6cbb8b024e9b8257d7f84cc74db1a5e63e6d495a33970d0c83ed95675914539d9217 SHA512 009542d370248989489e4d2a557b5f5cac27923bc06b9a9088b282f3f9cc8b31bfc43bba9cff3a44f8a77e20356b8a9ced60ec200b26815780af5588efbc9e4b
+DIST pyswisseph-2.05.01_pre20160529.tar.gz 488382 BLAKE2B 3bcea971448b13c40f440473ce2da13ca18796ab645265ae813fed517ca7062342170e0526b48a19b8686ac82526a16654b7c8e4b7d2dcd8e854c116d1fbf911 SHA512 afec6ce93a34ee116ed5247ff0004cf7c3adce33b4e0f95aa251b6b533a8925340d6f6d847ab80dfb2cf75933939d282455e7dc1f812c28ad45a42f21ce1e611
+EBUILD pyswisseph-2.00.00_p2.ebuild 646 BLAKE2B 18798311c7d453908aed1473e27f8d75ac4ea44f621340871c4d777befcc79dcfb48f079e31c2f9c02ebc783143d16e0f0c624edc4eeaa5d6206aee58058d97d SHA512 7f0cd349401692f044d4a7829627d848f6c90dc9ae2c4b45ad6686ea4a1386d7248d53e97d0c7df1d8503586841d4ed646cf4100657a51dc42e60ce1da75b083
+EBUILD pyswisseph-2.05.01_pre20160529.ebuild 665 BLAKE2B 755ce7cce89be3bac672a9ba11d5dca6e9e6250d8f0bf47e24e6da495083b355fb2c91e0b0bd520bd62e0df724741fa12de11e998af27aff5af29135e5596ef8 SHA512 0a321a8ea2b497e29a062454511997a8da8c6862c280641cf830e49c8f15b6a7ff07a63c38267557e8899e98ead0222d2e072eca5e261ecc887ca8bf6149bbfe
+MISC metadata.xml 511 BLAKE2B d88458ce79785b22bd75c3b39e845dc0a91cfb30aaaee7780e15b422edf1dd8fa0decf325238bbf34c469756fa31cba346a3cf8b9dcd7659a4a39bc967519f88 SHA512 b81b9b0110b7460c3a308a4a914ad59ccf21e1d5b003c898167b803b57720cb66e29d070d6998a6747d61039be9a364d907e517cee2ad31f7ad533e687d756ad
diff --git a/dev-python/pyswisseph/metadata.xml b/dev-python/pyswisseph/metadata.xml
new file mode 100644
index 000000000000..90e4eddc1f38
--- /dev/null
+++ b/dev-python/pyswisseph/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <bugs-to>https://github.com/astrorigin/pyswisseph/issues</bugs-to>
+ <maintainer status="active">
+ <email>smarquis@astrorigin.ch</email>
+ <name>Stanislas Marquis</name>
+ </maintainer>
+ <remote-id type="github">astrorigin/pyswisseph</remote-id>
+ <remote-id type="pypi">pyswisseph</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyswisseph/pyswisseph-2.00.00_p2.ebuild b/dev-python/pyswisseph/pyswisseph-2.00.00_p2.ebuild
new file mode 100644
index 000000000000..0f594661e4af
--- /dev/null
+++ b/dev-python/pyswisseph/pyswisseph-2.00.00_p2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+PLEVEL=${PV##*_p}
+MY_PV=${PV/_p*}
+MY_PV=${MY_PV}-${PLEVEL}
+
+DESCRIPTION="Python extension to the AstroDienst Swiss Ephemeris"
+HOMEPAGE="https://github.com/astrorigin/pyswisseph"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/astrorigin/pyswisseph.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${PN}-${MY_PV}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
diff --git a/dev-python/pyswisseph/pyswisseph-2.05.01_pre20160529.ebuild b/dev-python/pyswisseph/pyswisseph-2.05.01_pre20160529.ebuild
new file mode 100644
index 000000000000..8e263a47436b
--- /dev/null
+++ b/dev-python/pyswisseph/pyswisseph-2.05.01_pre20160529.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python extension to the AstroDienst Swiss Ephemeris"
+HOMEPAGE="https://github.com/astrorigin/pyswisseph"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/astrorigin/${PN}.git"
+else
+ COMMIT_ID=4f76befee7e39dff96b4c068cc6ce5fa66fb021c
+ SRC_URI="https://github.com/astrorigin/${PN}/archive/${COMMIT_ID}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}-${COMMIT_ID}"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+DEPEND=""
+RDEPEND="${DEPEND}"