summaryrefslogtreecommitdiff
path: root/dev-python/pytest-aiohttp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-25 06:47:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-25 06:47:12 +0000
commit4dec849539ecb0ceab14d66af84960f01b9a284c (patch)
tree70e3b3443839fd480586c6a3bc5f95ac0087603d /dev-python/pytest-aiohttp
parentf1e6490ffadd8d677960342b348f2b08492dd5f6 (diff)
gentoo auto-resync : 25:01:2025 - 06:47:11
Diffstat (limited to 'dev-python/pytest-aiohttp')
-rw-r--r--dev-python/pytest-aiohttp/Manifest2
-rw-r--r--dev-python/pytest-aiohttp/pytest-aiohttp-1.1.0.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pytest-aiohttp/Manifest b/dev-python/pytest-aiohttp/Manifest
index b88e56619757..61912b5319e0 100644
--- a/dev-python/pytest-aiohttp/Manifest
+++ b/dev-python/pytest-aiohttp/Manifest
@@ -1,3 +1,5 @@
DIST pytest-aiohttp-1.0.5.tar.gz 12209 BLAKE2B b02154239a6073bafac3d8be70a7ae8ff13fefdd09941db558c0b1ad31d14c5e29131209f157ab418202852a2d97f151d765cfffe0de06aac57f0c983ea99518 SHA512 b8421c63e4d5caa9742a013a6d1fd3c010b5e4a48e4f5c1a07ddfb7b05853ce6a7a0d65ce78493fd607f59c669d31c75d97a9022048e6a60cbc90a19a48dd02c
+DIST pytest_aiohttp-1.1.0.tar.gz 12842 BLAKE2B 96a9164d041e417a9176aba97ade3eb22a58ec7042de38745956b0a9525389f1615b626cf014d86df78491b948f7f6820b25dceb58937b674d2ca33aa534e38c SHA512 891a379535f1ecc9e74282d813cfc11b74c79c852d08e94942e1bb29c0eafecdce73ffbf6aefce24c37315c502bdfe0861bc97b6be1489dd3dd59b2aa215f4e8
EBUILD pytest-aiohttp-1.0.5.ebuild 914 BLAKE2B 790e70d634c2303aed599c7edeaf7d6c9b0a4cbe2ec62fc44d89a8b9017721fbcfdd992ba6c43ab9cccfc13efe1f53f5e261bfccabc2edbd2680734c12b61800 SHA512 2fabb81867a54596f20f4c293db458e6bf0fd2266c6d5ffc7f841e5ab30844c26fc9ada856bb064cdcdad371792edbc561de8a79e1c05e2ee5d8321831f39d6f
+EBUILD pytest-aiohttp-1.1.0.ebuild 909 BLAKE2B b3e5f53ae87680f855106ff502eb4dc882fe1e83fe7a64f60fc9f436b426fa0a348502972db57588075c5a7b44da0b26baa1ac27150d7c6e8d6810b64db07d9a SHA512 6c2764c5558692424a318b6c375c1feef87f7650d1f1b110fef62ff4a09e9a05d7b0ff6d3c82163a10988cabb4a2838635afc1d2608b6270c2b26c886b18175d
MISC metadata.xml 383 BLAKE2B aef07c31a48de61fffa14c250aac7d1de63b652f94d83c52d32df2100da3bc5be19f224078b1b984520cc7e0b3d80838379388aa4c0e9531317a79dca178370c SHA512 b73d692782a9eae48022738bbcf3771605c8d00bf73ab2499cc27f309069bb80a402cd1ce618df29de7dfd11c226514aa3ec7d78df1ea784c7221691febf06f9
diff --git a/dev-python/pytest-aiohttp/pytest-aiohttp-1.1.0.ebuild b/dev-python/pytest-aiohttp/pytest-aiohttp-1.1.0.ebuild
new file mode 100644
index 000000000000..cd49d9d5d729
--- /dev/null
+++ b/dev-python/pytest-aiohttp/pytest-aiohttp-1.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="pytest plugin for aiohttp support"
+HOMEPAGE="
+ https://github.com/aio-libs/pytest-aiohttp/
+ https://pypi.org/project/pytest-aiohttp/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/aiohttp-3.11.0_beta1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.17.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-6.2[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # warning doesn't seem to be emitted for some reason
+ # doesn't look very important
+ tests/test_obsolete_fixtures.py::test_loop_fixture
+)