summaryrefslogtreecommitdiff
path: root/dev-python/pytest-aiohttp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/pytest-aiohttp
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/pytest-aiohttp')
-rw-r--r--dev-python/pytest-aiohttp/Manifest4
-rw-r--r--dev-python/pytest-aiohttp/metadata.xml15
-rw-r--r--dev-python/pytest-aiohttp/pytest-aiohttp-0.1.3.ebuild24
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pytest-aiohttp/Manifest b/dev-python/pytest-aiohttp/Manifest
new file mode 100644
index 000000000000..c6011676efc2
--- /dev/null
+++ b/dev-python/pytest-aiohttp/Manifest
@@ -0,0 +1,4 @@
+DIST pytest-aiohttp-0.1.3.tar.gz 6192 SHA256 c2391c424b5342f9234f5f56f15183d167050b50c08c96258c1816cdb5a0283f SHA512 2271f7730b91812a619e04522c13b7e2ff76353179a4588226d0b943b67f7397b966c1d3c24016861cc3eda3a541b3f0d3b2858a6ca3586f7707e10581c34e4c WHIRLPOOL 8bf1608b655db5cc3a932316e48fbff6ab4045971e5e0d2e7240219798bcffdb2f130a8270163b67d8f213a15242127721b128b0edb2a97fa8e07f1ce2026d98
+EBUILD pytest-aiohttp-0.1.3.ebuild 567 SHA256 0d2738877639064909f1b505080e8fb450e9d063f71ef2f8c35045859b1c8cfa SHA512 5c8d342844f8db2ef4281f113904e97f07f9900189c608db57298686a61c72db6e49e9277d9c4581d74cb41692893569ee8f61269af44aecca0a7860eb44e9a6 WHIRLPOOL 37ff858e62dcfa96b8d54f29a49d06ffff8545331a78c59ced02bf011b66db6253dafd84693411c5400d0c6a5639a64807a0196bf458057256f0c2b9feffdc97
+MISC ChangeLog 333 SHA256 349ddb0f2728e3816c7c701b8b1fcbb8e308eae0ed62c7ab4bb165f343568e50 SHA512 555148f01d921b26626a58aa4b1574868a25d63b796eb1930d1decea2332a82f41c79d0720217c6bdf6d5676f0ce639bc8398d9f13556085a53ac6fdf9b713fb WHIRLPOOL 4c7e9cc67bb194bfc2a40046ca48792033be986c54b7bea9031973f37e1397796913a6d2fbd8e32c0358b51e8283dcb3150d9f1d0ca77f639158401e270798f0
+MISC metadata.xml 465 SHA256 b4aa1e5efdb6a0c8661b08f1bca4bc5e302d9fcc180270f2999e925cd9478b76 SHA512 545283f1c6686667208d083e47714b66e2da2ff09f27bbdb9b10809945389f912e9e2bcfda4f0398ea0e6bc30586146e2a113bc2f8056406b3716c39ceccf55c WHIRLPOOL 9f5d4286f66ad613baedbd237c86b1ac02629205338cc44d773981665ad508799346a587abf05e38355808f499d4a94bcb233817c24e8d1ce654613e86f16cec
diff --git a/dev-python/pytest-aiohttp/metadata.xml b/dev-python/pytest-aiohttp/metadata.xml
new file mode 100644
index 000000000000..ddd61db2af48
--- /dev/null
+++ b/dev-python/pytest-aiohttp/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>alunduil@gentoo.org</email>
+ <name>Alex Brandt</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">aio-libs/pytest-aiohttp</remote-id>
+ <remote-id type="pypi">pytest-aiohttp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-aiohttp/pytest-aiohttp-0.1.3.ebuild b/dev-python/pytest-aiohttp/pytest-aiohttp-0.1.3.ebuild
new file mode 100644
index 000000000000..e0262e7f2199
--- /dev/null
+++ b/dev-python/pytest-aiohttp/pytest-aiohttp-0.1.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin for aiohttp support"
+HOMEPAGE="https://github.com/aio-libs/pytest-aiohttp/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ >=dev-python/aiohttp-0.22.0[${PYTHON_USEDEP}]
+"