summaryrefslogtreecommitdiff
path: root/dev-python/pytest-asyncio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-15 02:02:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-15 02:02:03 +0000
commit16a4365c3b854e62b50726456ddb29bb78fd5038 (patch)
tree6de11adc70daeb6424485bb16be162d2cb277018 /dev-python/pytest-asyncio
parent59d772d9463f8cf6a145a677bedbf377a0625aff (diff)
gentoo auto-resync : 15:12:2024 - 02:02:03
Diffstat (limited to 'dev-python/pytest-asyncio')
-rw-r--r--dev-python/pytest-asyncio/Manifest2
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.25.0.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/pytest-asyncio/Manifest b/dev-python/pytest-asyncio/Manifest
index bccf724bed84..fee456a46457 100644
--- a/dev-python/pytest-asyncio/Manifest
+++ b/dev-python/pytest-asyncio/Manifest
@@ -1,5 +1,7 @@
DIST pytest_asyncio-0.23.8.tar.gz 46920 BLAKE2B 6b7a66e6ef28f2c7a874a115e0346b3803051df5d57e5b8ba35480982231a804adfbe8a4a2c605847730ea940fafe9df2aa94f5081b43aa753b64c3e2ea027a5 SHA512 68f23458c5f22bdb75a6a0a12f185b1f22c5231c0cdcd84806781419f5c866844e851398d771c5932af4a42b5dfdcce6624181f2c0d2f70187bb5feed0ba7c97
DIST pytest_asyncio-0.24.0.tar.gz 49855 BLAKE2B 55813b655252f2c1fbe1658a0a2d739bb03a56794297dde9cf598b8200c0d3aa7437af7a241a821eff47ffe57841142adb93c6434c920cbd1d26b33a8ac8fe96 SHA512 abf2442afb9f5933b223e920c0b107d5781350f2a9c2e58ca141494a4f391acf97f2e377db1fc67b5213031bf371f222dc9c4718ff3c6b5985f5e49913f03cb7
+DIST pytest_asyncio-0.25.0.tar.gz 53298 BLAKE2B e29641f9e0ae24aac80bca7eaa14258d0bdfa6080abeaedd38ffe121cb9a9bf5886da2a38a3033010fcb47f4c2aee0eb17b0f63cee020c5ae81e8334486c66b7 SHA512 162d1693c82c4be96cf20cfeb075c4e434e897cdfc172564b8b2513b362a6bbf54d8be6da4a63a7de34236b6c55eb515e60b994198c07a5c63a63333fe019932
EBUILD pytest-asyncio-0.23.8.ebuild 1579 BLAKE2B 11414e0f77a9f77275af1f838c4cdfc4c9be5577baa38fe899d0f40d1757557025eebc96e8c5370ee573327407c8fcea4e6fcf9edf8e30a7210788d3b074c498 SHA512 5f7cd4b58e2c0cfe3e2655cdba87472130a9f28d38dd147b18f9fbf006c21781fb3428202235f0fac9cb55ac5c6bbebc050053297a004f6781b37a51c213ac6b
EBUILD pytest-asyncio-0.24.0.ebuild 1250 BLAKE2B 53bda92a77b339742bbd635a9e24e22f9cdf040235cad3bd9ac3c0ae945cd0d70d70c1cb0e327db978998ed2c8a0dafa5c5efe6b5434a6d17efb41c1a9ee58ec SHA512 a622fb37a89ad2de3333c866c8cc66f5cf29f6ce386653a0e1e1ef53dee21f04c9ec24f60dc82c22044009d340557c29920443201a240ddcd4317aef51a39cb6
+EBUILD pytest-asyncio-0.25.0.ebuild 1259 BLAKE2B 2cdf8b0e5e05315b079ef5ef006888021b5c97c789b760edf1e5d3e182e81db5342cff5965de7ede0d7fe6634c7553c6ef098094902432a4c4399937e672e619 SHA512 1195eee4259b09b9114b80ecf586c088398c6169dca11bab2ad0ee8950c6b8a0d801c72ec49d496b1691db2c5ab30494933f5fe0e473361af02755ab234a86b8
MISC metadata.xml 385 BLAKE2B 3d8faba48e1b3e531ea338f08f2de4b7bf637190e65fc61df2bd4d994cc97707016f83927f4a5181ac27d412a8c91255e90caba15f2d687f2339bc8ea61b18f2 SHA512 71178d3fba362e7532c87cb519f3661b25018771b86c302660de11f1bc7817b8352a2c8fcf60084a5e62b15148307a360267381ac38e8c856784034d80327d4d
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.25.0.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.25.0.ebuild
new file mode 100644
index 000000000000..06f24e2dc19f
--- /dev/null
+++ b/dev-python/pytest-asyncio/pytest-asyncio-0.25.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Library for testing asyncio code with pytest"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-asyncio/
+ https://pypi.org/project/pytest-asyncio/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/pytest-8.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/hypothesis-5.7.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on precise warning counts
+ tests/hypothesis/test_base.py::test_can_use_explicit_event_loop_fixture
+ tests/test_event_loop_fixture_finalizer.py::test_event_loop_fixture_finalizer_raises_warning_when_fixture_leaves_loop_unclosed
+ tests/test_event_loop_fixture_finalizer.py::test_event_loop_fixture_finalizer_raises_warning_when_test_leaves_loop_unclosed
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_asyncio.plugin,_hypothesis_pytestplugin
+ epytest
+}