summaryrefslogtreecommitdiff
path: root/dev-python/pytest-asyncio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-20 00:35:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-20 00:35:55 +0000
commit84be07a71d5002585ac714a892bbfd57f3091b4e (patch)
tree0fe24d663efe493f7c44c5dea33b63bb2364e706 /dev-python/pytest-asyncio
parent810f2cdadf662a6bfaaed425b6ecd216a301cd3d (diff)
gentoo auto-resync : 20:03:2023 - 00:35:55
Diffstat (limited to 'dev-python/pytest-asyncio')
-rw-r--r--dev-python/pytest-asyncio/Manifest2
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.21.0.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/pytest-asyncio/Manifest b/dev-python/pytest-asyncio/Manifest
index f8ad958f3005..b45cd3128dec 100644
--- a/dev-python/pytest-asyncio/Manifest
+++ b/dev-python/pytest-asyncio/Manifest
@@ -1,3 +1,5 @@
DIST pytest-asyncio-0.20.3.gh.tar.gz 27695 BLAKE2B 6e6f0d58d0f985cee9dc0b27f886d0b1b4b54ecbf4980c4ac59b420d6e6e5c01d1c6f3c9ed803391910124f19ee3a882c963f10e5f6bab6de6115bfa222c8be2 SHA512 78a6e251db80696d6f62a54c8d6836e2a820f27efdaa848eb1be512a1592d3bd3fb7c7eee46bb2039a317a8d431565614c888f8436fbe0d4eb60534ce4780e90
+DIST pytest-asyncio-0.21.0.tar.gz 29898 BLAKE2B 6455e59a2e28ddbefd54e4c16970d36d22a674406fbc0e352e9886af3a7a51a0ae4a8ce32e01d076e2411f0501548092dfbe3150d87c14cb5e5eb71966bcb743 SHA512 ce557e5f15f3ae745804f4484d590a9f673d76f0c67c2e8ab444e1b17a4ae5ea6021bf55d7ef905643bfbcded6299f207a386fb4dc05ddf20ade25e6618a9773
EBUILD pytest-asyncio-0.20.3.ebuild 1266 BLAKE2B 0edfbdafb247caa37432e63543cec41c7209c365123129ff748a7e4b8ae853ccbe3c598286087545780b348ede53b011453d4706c0add709f9403f5f1ba2ce39 SHA512 bf026ad5852717800e192f7f5a213ab872a19aaa58f95195a3e2655aca6c502ac13ed985a2ce14e35f3b14b01c805bc0e5127a6316cb5b9ea8e0be08d2c2b960
+EBUILD pytest-asyncio-0.21.0.ebuild 1421 BLAKE2B c27330791fd1210cc6e02bc20e62c0a6289ce955e18651c913f26e835f8361f421cf156894b3909c1831cf9857d93d719e84e21e4dd6353affd3693687c48065 SHA512 4bcc77f3d01c222e0a50abe866282c5e85c1cfa76e24ceae423ce490f96a4cbbee5643257e4339c6ec5f6912dd7786cabcc8fb44ae42bc22ec7a713085726f5d
MISC metadata.xml 385 BLAKE2B 3d8faba48e1b3e531ea338f08f2de4b7bf637190e65fc61df2bd4d994cc97707016f83927f4a5181ac27d412a8c91255e90caba15f2d687f2339bc8ea61b18f2 SHA512 71178d3fba362e7532c87cb519f3661b25018771b86c302660de11f1bc7817b8352a2c8fcf60084a5e62b15148307a360267381ac38e8c856784034d80327d4d
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.21.0.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.21.0.ebuild
new file mode 100644
index 000000000000..6eb231250e27
--- /dev/null
+++ b/dev-python/pytest-asyncio/pytest-asyncio-0.21.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Library for testing asyncio code with pytest"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-asyncio/
+ https://pypi.org/project/pytest-asyncio/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/pytest-5.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on precise warning counts
+ tests/test_pytest_min_version_warning.py
+ tests/modes/test_legacy_mode.py
+ tests/trio/test_fixtures.py::test_strict_mode_ignores_trio_fixtures
+ tests/test_event_loop_fixture_finalizer.py::test_event_loop_fixture_finalizer_raises_warning_when_fixture_leaves_loop_unclosed
+ tests/test_event_loop_fixture_finalizer.py::test_event_loop_fixture_finalizer_raises_warning_when_test_leaves_loop_unclosed
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_asyncio.plugin,_hypothesis_pytestplugin,flaky.flaky_pytest_plugin
+ epytest
+}