summaryrefslogtreecommitdiff
path: root/dev-python/pytest-asyncio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-python/pytest-asyncio
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-python/pytest-asyncio')
-rw-r--r--dev-python/pytest-asyncio/Manifest2
-rw-r--r--dev-python/pytest-asyncio/pytest-asyncio-0.18.3.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pytest-asyncio/Manifest b/dev-python/pytest-asyncio/Manifest
index 5bfb5fc813a6..c966cd2d34a4 100644
--- a/dev-python/pytest-asyncio/Manifest
+++ b/dev-python/pytest-asyncio/Manifest
@@ -1,5 +1,7 @@
DIST pytest-asyncio-0.17.2.tar.gz 23805 BLAKE2B 0501a193518cefb0596b1595a58e8f18915b61ba2b502726b457e78c10b5849e5fc1980192d4b5aceb7499af15556c185efc42b76153e2b8f72ab4e36249ad23 SHA512 f1f6a586a7a3a1672ed76e8758a76e8bd427b0da055461597ab3b6296e3ae50002a9a259aba57f0b6191d606db6fa61377dbf03099d3437272a4a1f4144aa58e
DIST pytest-asyncio-0.18.2.tar.gz 24515 BLAKE2B d583abe16c215f12a3cc93588d40b9b75188b3a19eb3b4a018551f7fe616e92c73e12c0be6e6a3eadd7357b2396f397013829e1827bf0fc0cb4b96cdd1e64ff4 SHA512 377d219e731ac97a69e143c2de2e327f7293baf4af4bf370cb84dde4f94f705e315bf6deaea4b7d8c1d6cbc54ed753e15ccc0b21a0cef6c3397a560aae684f9e
+DIST pytest-asyncio-0.18.3.tar.gz 25049 BLAKE2B 5439675fd03b7fdd4cd3dbf1f37daa83d6b18b199ccc7b54acc648187dffcf59154f8f0ec5d4144ed40554290343a0890952e67d4184b17b0a3817196592023e SHA512 04d2046c039131598cb593afc1908be0dff2b24a91c89f36fca75d2d65916571e48fe149c1ba90244f299586277320cf6f130a02824fde9ee0a4d2429bf58a54
EBUILD pytest-asyncio-0.17.2.ebuild 958 BLAKE2B 4852d2d0ecbf808dffbd9e76e86850b2616aa8bcea74d5c62ee14a5ca884df4d787874cb59f137c02e0d78fe5e3cdb7192b71cd2d25ac06b06c34f48cb4d9626 SHA512 1464b7a2a69a2aeec396e6dedca2c740b8231d704ad9da4a5931d73af483a5a166a554e566428e6e655ae98ab6d88f653172c07f3b26c6cdd68a6df0f2a001dc
EBUILD pytest-asyncio-0.18.2.ebuild 966 BLAKE2B 33befc28a63ac9adb792606c7c991d510970bac16b3b8abca8277b725d694b7a540db452a2bcf2523445627254e957982aa79f540c70e36f0fb3894759e5142b SHA512 267a48cc5c6c0b588ba2e84dba0f84557dc145575add05b85e936e13b8d75ef52cabf428f71548d18f1b022d9514da41656b2bf8e5eaaae9fddf731a24814cf1
+EBUILD pytest-asyncio-0.18.3.ebuild 1035 BLAKE2B 98a43e95a46e7c10654b9a12925be852906b4e52509b728192abd03d300dc566da11cb89cd58935c4c009ee0d79eb92c6f6991d8288660e9da188016c2df15b0 SHA512 71a6035c938223a4f63610df5bfa7f9a962f82bd543fd16d67cc15b2980c0d661dcb943bc417600c3c711f0529786b5dbebe34b0a4658e7b5c656d96a7a99db6
MISC metadata.xml 385 BLAKE2B 3d8faba48e1b3e531ea338f08f2de4b7bf637190e65fc61df2bd4d994cc97707016f83927f4a5181ac27d412a8c91255e90caba15f2d687f2339bc8ea61b18f2 SHA512 71178d3fba362e7532c87cb519f3661b25018771b86c302660de11f1bc7817b8352a2c8fcf60084a5e62b15148307a360267381ac38e8c856784034d80327d4d
diff --git a/dev-python/pytest-asyncio/pytest-asyncio-0.18.3.ebuild b/dev-python/pytest-asyncio/pytest-asyncio-0.18.3.ebuild
new file mode 100644
index 000000000000..160168fbf8b3
--- /dev/null
+++ b/dev-python/pytest-asyncio/pytest-asyncio-0.18.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Library for testing asyncio code with pytest"
+HOMEPAGE="https://github.com/pytest-dev/pytest-asyncio
+ https://pypi.org/project/pytest-asyncio/"
+SRC_URI="https://github.com/pytest-dev/pytest-asyncio/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/pytest-5.4.0[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-3.64[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+EPYTEST_DESELECT=(
+ # rely on precise warning counts
+ tests/modes/test_legacy_mode.py
+ tests/trio/test_fixtures.py::test_strict_mode_ignores_trio_fixtures
+)