summaryrefslogtreecommitdiff
path: root/dev-python/pytest-bdd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-21 07:03:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-21 07:03:54 +0000
commit1ad2c51f9cc380c164b03ed03acda1c3fcc0a476 (patch)
treedd39d93cbea55db38069a7fed0a1c8667b7d88b3 /dev-python/pytest-bdd
parentd32022e7301aef2b3f52f6b7a3de81c6e03ffcaf (diff)
gentoo auto-resync : 21:11:2022 - 07:03:53
Diffstat (limited to 'dev-python/pytest-bdd')
-rw-r--r--dev-python/pytest-bdd/Manifest4
-rw-r--r--dev-python/pytest-bdd/pytest-bdd-6.0.1.ebuild40
-rw-r--r--dev-python/pytest-bdd/pytest-bdd-6.1.1.ebuild8
3 files changed, 7 insertions, 45 deletions
diff --git a/dev-python/pytest-bdd/Manifest b/dev-python/pytest-bdd/Manifest
index b86044fec279..186f32229134 100644
--- a/dev-python/pytest-bdd/Manifest
+++ b/dev-python/pytest-bdd/Manifest
@@ -1,5 +1,3 @@
-DIST pytest-bdd-6.0.1.gh.tar.gz 60932 BLAKE2B 67e0dbc251ce94da40033641f37e6c9ad70ca947f71db1a78907a6890d96d8d3112d57a2a63dda526c8f846010d39a575cb5d93a102f4653705d4229ee14ab07 SHA512 30bc697ae177e3f311af0c781e99bde5b491dfef28109359c0d80f33feb8b0b170ffe15c288fe73a624144a1d1c3223b220d591b4acc30d1ad53600482bef87d
DIST pytest-bdd-6.1.1.gh.tar.gz 79549 BLAKE2B 0de77a2a46c852dcd7b344b385deea6473ec32dfec2eec610ae04d9d192d42eaf7aa3b1455549dc602e46c24edf078c558f2564aa9dd7f42a2beea36458438ea SHA512 69cd345d4a819a84a811ca2a5825f87a46fa4d063b9a852308d36e4f15058a27c45b170dadf684e68322d3380654f985b8ef153e34ad42ef33e0b595f8dc9d96
-EBUILD pytest-bdd-6.0.1.ebuild 1084 BLAKE2B baa7bbb71d57683cb4b03dc4fb15ffb510d214df05fdf714767767a73846b6543188ab4af6b931db3c3362cad3b945e271979837f1168a04dcb32c9acdf06549 SHA512 2df002e33e225db79ddb3f6afc9c70e7d1d6f0ef29aad3c8f44189cb9b86faa430053dcba31c3ddb2ce6f8ba5367873d61688b0cc6ffc3208af49868eb566118
-EBUILD pytest-bdd-6.1.1.ebuild 1060 BLAKE2B 692476c5c0f0fd307843650d1a4c4e73ef612149739d75a5ba4a37326c6cbf34d30f347cb76d8715ae99e10d97c81123da89767e150967d35718dfe12cbf898b SHA512 4ad8dfe906c93d24a6746e3b9b16a379634dbe7382b835ad862da881ad6fdc7ead4f95646a91cd2b45eae487bb8cbe1c3578f3cf8262f8bf081f24425953e9f4
+EBUILD pytest-bdd-6.1.1.ebuild 1106 BLAKE2B 500ed1bf214c074cb13f1df478dddc020d470a44f6cd21a1f1a69af2c32b791e53f9f216efe25da32d4d8188bab4729d94ca6c056c917df64efc3922da9ea226 SHA512 333b076aa7cd4bd7253ae15e9cf9598083c15618451fdd0f749bcde77251956d2d02e76cad27cb9cf39123a40e1ea16f82e006670a56673b42a76f91580de2e2
MISC metadata.xml 404 BLAKE2B b5bdea28ab998a54bd0b76e38c37a77af74d4ae149bfc5af47e7466b7c13ae6a5784be0ecc3e6cd8ccbbd5164dea02d704f596b7e00d22b0d640c4ad3dd13b41 SHA512 97800a5877bd8f3aa880a0cdff19cc89de983ec1a0cd9fbe2c74178b6fc214a0ca7fbb013b2ac490e1c4109f03ded7055e1517a3b57f6da0d79c9f5ea5864e77
diff --git a/dev-python/pytest-bdd/pytest-bdd-6.0.1.ebuild b/dev-python/pytest-bdd/pytest-bdd-6.0.1.ebuild
deleted file mode 100644
index 7682168ff49b..000000000000
--- a/dev-python/pytest-bdd/pytest-bdd-6.0.1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-inherit distutils-r1
-
-DESCRIPTION="BDD library for the pytest runner"
-HOMEPAGE="https://pypi.org/project/pytest-bdd/"
-SRC_URI="https://github.com/pytest-dev/pytest-bdd/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~x86"
-
-RDEPEND="
- dev-python/glob2[${PYTHON_USEDEP}]
- dev-python/mako[${PYTHON_USEDEP}]
- dev-python/parse[${PYTHON_USEDEP}]
- dev-python/parse_type[${PYTHON_USEDEP}]
- dev-python/py[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]"
-BDEPEND="test? ( dev-python/packaging[${PYTHON_USEDEP}] )"
-
-distutils_enable_tests pytest
-
-DOCS=( AUTHORS.rst CHANGES.rst README.rst )
-
-src_test() {
- # terminal_reporter test needs exact wrapping
- local -x COLUMNS=80
-
- # hooks output parsing may be affected by other pytest-*, e.g. tornasync
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytest_bdd.plugin
-
- distutils-r1_src_test
-}
diff --git a/dev-python/pytest-bdd/pytest-bdd-6.1.1.ebuild b/dev-python/pytest-bdd/pytest-bdd-6.1.1.ebuild
index 5d7b8445abb2..39ee70789605 100644
--- a/dev-python/pytest-bdd/pytest-bdd-6.1.1.ebuild
+++ b/dev-python/pytest-bdd/pytest-bdd-6.1.1.ebuild
@@ -13,7 +13,7 @@ SRC_URI="https://github.com/pytest-dev/pytest-bdd/archive/refs/tags/${PV}.tar.gz
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
+KEYWORDS="amd64 ~arm64 ~x86"
RDEPEND="
dev-python/mako[${PYTHON_USEDEP}]
@@ -21,7 +21,11 @@ RDEPEND="
dev-python/parse_type[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/typing-extensions[${PYTHON_USEDEP}]"
-BDEPEND="test? ( dev-python/packaging[${PYTHON_USEDEP}] )"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ )"
distutils_enable_tests pytest