summaryrefslogtreecommitdiff
path: root/dev-python/pytest-click
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-29 02:06:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-29 02:06:03 +0000
commit2a3c08f4647671d17f534a5dbd8bd45e11c90ea2 (patch)
tree67ecd2d13b251a03c4834bdec638d301818901eb /dev-python/pytest-click
parenta2148b9fab4c83209816a49f091d70873b19881d (diff)
gentoo auto-resync : 29:11:2024 - 02:06:03
Diffstat (limited to 'dev-python/pytest-click')
-rw-r--r--dev-python/pytest-click/Manifest3
-rw-r--r--dev-python/pytest-click/metadata.xml12
-rw-r--r--dev-python/pytest-click/pytest-click-1.1.0.ebuild28
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pytest-click/Manifest b/dev-python/pytest-click/Manifest
new file mode 100644
index 000000000000..ac18509f0f2f
--- /dev/null
+++ b/dev-python/pytest-click/Manifest
@@ -0,0 +1,3 @@
+DIST pytest_click-1.1.0.tar.gz 5054 BLAKE2B ad14c214ff767293d75a02930cc9852b97145c5554b6c4aa112e523a6d3e95fa967931c0a3b0beee3e2a69cd8df0d1c2c1bf33f351c3585cb446e1cd6efa5cad SHA512 49ab5fd3499cc519172f364505f1884596c0b45ebc1b64245cfc235f70d2c4765d133d69615300429b4010f28ab725941f53219f4f0ae6520b452a22503886a1
+EBUILD pytest-click-1.1.0.ebuild 557 BLAKE2B d8fe2c32c3914c1422f4632a08472cfe05dceda023573d557497375ccdf7b76af16bfed5bc5a268620ae18a59b039d9165898f055e1aae4ca3d8694307ab588b SHA512 f8f13020aca2195bd8a3803eedd42ee9f61673bf12629445b9b2c165aaf05662314723d657354650faecca0eeaa529b0dabf62e7aa3509252c5f660d4a400623
+MISC metadata.xml 383 BLAKE2B 844da641f8ef39530fcde558e026db5da89e169288cc5c42f9051b52135e3eafed261c91f22d91af719d6fd5abf251c0d05a18cd00e622809bb1d06d01ac9a83 SHA512 11865eba7beb6521fe5bfdd82bfcf8d4ac4c396a21b9847380304abfd4ec6ac025b91619b823320b36431171a0873cf83a995ada310d1332260cecbad609bfa3
diff --git a/dev-python/pytest-click/metadata.xml b/dev-python/pytest-click/metadata.xml
new file mode 100644
index 000000000000..2153c19b38fd
--- /dev/null
+++ b/dev-python/pytest-click/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">Stranger6667/pytest-click</remote-id>
+ <remote-id type="pypi">pytest-click</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-click/pytest-click-1.1.0.ebuild b/dev-python/pytest-click/pytest-click-1.1.0.ebuild
new file mode 100644
index 000000000000..07e94bdecb7e
--- /dev/null
+++ b/dev-python/pytest-click/pytest-click-1.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pytest plugin for Click"
+HOMEPAGE="
+ https://pypi.org/project/pytest-click/
+ https://github.com/Stranger6667/pytest-click/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+DOCS=( CHANGELOG.md README.rst )