summaryrefslogtreecommitdiff
path: root/dev-python/pytest-codeblocks
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /dev-python/pytest-codeblocks
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'dev-python/pytest-codeblocks')
-rw-r--r--dev-python/pytest-codeblocks/Manifest5
-rw-r--r--dev-python/pytest-codeblocks/metadata.xml17
-rw-r--r--dev-python/pytest-codeblocks/pytest-codeblocks-0.12.2.ebuild28
-rw-r--r--dev-python/pytest-codeblocks/pytest-codeblocks-0.9.0.ebuild21
4 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/pytest-codeblocks/Manifest b/dev-python/pytest-codeblocks/Manifest
new file mode 100644
index 000000000000..8c9b7a15d2ec
--- /dev/null
+++ b/dev-python/pytest-codeblocks/Manifest
@@ -0,0 +1,5 @@
+DIST pytest-codeblocks-0.12.2.tar.gz 8547 BLAKE2B d5bfea250aa2fc955eab5b8e96bb942c119b44367fa2f9e8cab8350409a7dbf697c16e3193ad18e629d7f4ccbb2ddc1f4fbce4cead96167cf16d1b6a922fdd91 SHA512 d69819106b389ce3cd2d04a1385e49f2bdf4eb70ea334175e6ba5e2921d77266ac2e69b22ce5a42880846555dd271e5b7dc25bda838b9238ad5d14add9389681
+DIST pytest-codeblocks-0.9.0.tar.gz 6590 BLAKE2B 34d1c72a891d2f2f1d98c4238322d888a48b286d628e3738043d16a59a75b3bd15b29e31c554a83508d9af31caf1b526e3c535a243bcf77c8d77f9bf5be69f5b SHA512 834002c4e9c8ad36baa9a4ed494fe28cf09460e0ee5a0a3d8d111cb0bd8ca4ed3c784a047901bc67984e7892f931b5644c1ea68112e4d9dda514a20e048b3d11
+EBUILD pytest-codeblocks-0.12.2.ebuild 621 BLAKE2B 28be35a995580aeb3d64d1b796763876000c06c497b4a62e7ad5ecb2f83bd2bf3a8fc2aab3742abd33cd257aeaee08ebe267e97f3007762b68efa38bc7a85e2c SHA512 96b51efb099e21c90bc41d641c1ed0cb44c7d7fcf6d3a9008bc05f050ae9f19b63bbe12b2e326be4e18c9b592c017e7b1a0fd31f17621a24dddfabe850601089
+EBUILD pytest-codeblocks-0.9.0.ebuild 489 BLAKE2B 108130fc625a07e64969491cbd32cca7566413c12482ca42f3e02b8a8451a10ac85db4b9066ab1beebdbc288ddce313c87aa6b79e05a026f6ae953e46ae6253b SHA512 80c766c497ee60cf9dae397060468e50df71cb81b27b4588d7f5028e28b3278655603d21c1178b1bd337ac35680238f22afc05b25c2ac684797acea2b822d4e4
+MISC metadata.xml 529 BLAKE2B 09fcee4e8de6e9206a8e1bcc11f185c163dd4014e4dee464d8e253ff18d9902b8e5445bbca6778b34ef6513014fed8454f0bc26d647bbd7606b3415dd2ee5aff SHA512 2238f717da848ba0472a236c3a0a1fb2ad50e16a15ffc7875e2d50d3a77ae25c3a1e8e26d606e2516a301bcf103a67d9ef59a2b54c807cd6f0cac72e70445c6e
diff --git a/dev-python/pytest-codeblocks/metadata.xml b/dev-python/pytest-codeblocks/metadata.xml
new file mode 100644
index 000000000000..7911d01e1748
--- /dev/null
+++ b/dev-python/pytest-codeblocks/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">nschloe/pytest-codeblocks</remote-id>
+ <remote-id type="pypi">pytest-codeblocks</remote-id>
+ </upstream>
+ <stabilize-allarches/>
+</pkgmetadata>
diff --git a/dev-python/pytest-codeblocks/pytest-codeblocks-0.12.2.ebuild b/dev-python/pytest-codeblocks/pytest-codeblocks-0.12.2.ebuild
new file mode 100644
index 000000000000..f1e55b3e131e
--- /dev/null
+++ b/dev-python/pytest-codeblocks/pytest-codeblocks-0.12.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Extract code blocks from markdown"
+HOMEPAGE="https://github.com/nschloe/pytest-codeblocks/"
+SRC_URI="
+ https://github.com/nschloe/pytest-codeblocks/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-python/pytest-6[${PYTHON_USEDEP}]"
+
+distutils_enable_tests --install pytest
+
+python_test() {
+ distutils_install_for_testing
+ epytest -p pytester
+}
diff --git a/dev-python/pytest-codeblocks/pytest-codeblocks-0.9.0.ebuild b/dev-python/pytest-codeblocks/pytest-codeblocks-0.9.0.ebuild
new file mode 100644
index 000000000000..9b5a314061f6
--- /dev/null
+++ b/dev-python/pytest-codeblocks/pytest-codeblocks-0.9.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Extract code blocks from markdown"
+HOMEPAGE="https://github.com/nschloe/pytest-codeblocks/"
+SRC_URI="
+ https://github.com/nschloe/pytest-codeblocks/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest