summaryrefslogtreecommitdiff
path: root/dev-python/pytest-cov
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-15 02:02:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-15 02:02:03 +0000
commit16a4365c3b854e62b50726456ddb29bb78fd5038 (patch)
tree6de11adc70daeb6424485bb16be162d2cb277018 /dev-python/pytest-cov
parent59d772d9463f8cf6a145a677bedbf377a0625aff (diff)
gentoo auto-resync : 15:12:2024 - 02:02:03
Diffstat (limited to 'dev-python/pytest-cov')
-rw-r--r--dev-python/pytest-cov/Manifest2
-rw-r--r--dev-python/pytest-cov/pytest-cov-6.0.0.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/pytest-cov/Manifest b/dev-python/pytest-cov/Manifest
index 7602a9636d33..4b816dd899ea 100644
--- a/dev-python/pytest-cov/Manifest
+++ b/dev-python/pytest-cov/Manifest
@@ -1,4 +1,6 @@
AUX pytest-cov-4.0.0-pytest-xdist-2.5.0.patch 750 BLAKE2B 018b270c47f1c19c19f9d72da935457a6042bcafa580d85f904d082fda9980d9a34579174b7b08551d6cedfbc6a6c7abd7be0216df0e21be64e49efe9d3dd1f5 SHA512 e8826ae013c7fb4cbe57975821faea9a8cfd2573befb4f961560e650cbced56e2dff3e02cde23e29e0bb5d06ce0d5893dc408c9e244ce014a5766c5a565f8efa
DIST pytest-cov-5.0.0.tar.gz 63042 BLAKE2B 6a0f3b38bbf6ae8843d804d078b3879e76ef146ba1bee2eb068bffe560332984994a8405964be185b2ededc2c8231288e609573c5a83143147eeb537659da1e5 SHA512 384459cafdb800711b935899acc3716f5fcbc28b40be0e168e58333603b1dea474bbd7a92f09b6afbe2f9dc1ce8599668a787c0f93884c263af894f44311a4a6
+DIST pytest-cov-6.0.0.tar.gz 66945 BLAKE2B 8746915eb23b7d524e15ece1a05d5a1c8de6e8e08b807142e9a03f48605d54f715396d73cdb4ee5004dc5703ac0f68309e700d783ebb2037fc861e00033c35f3 SHA512 2947a032417d60867595bb65630942ff5d8a61523af5298e3f169420b28882f9b4256d89980a9cbe88c34f9b7fa759f44fd64d391ad86c1491a55f9a70282bf0
EBUILD pytest-cov-5.0.0.ebuild 1640 BLAKE2B d22629eded726cb53bd441e0c2bb8ff4e65ccb92edea7188bf6d4f565face2570243d692c34614bca740f6cc1a03b0e980735263c2b1d522499b9f56fe43ebf7 SHA512 949b2a44494012c1d662d4e9491ba18273f4550b4b6ac5c1b5cf64431f522a8a7528b32f66f4bff96cd52a4f772eab77515ee1bc6c2fcc2dbb56ec0716961cc5
+EBUILD pytest-cov-6.0.0.ebuild 1646 BLAKE2B 811ab6e7bc93ba653c03951f9fe908c615ba48bc8b05c2629bec6efd88fa19943fe7e837b241bd62b8b7b19cb7ad279433257abcecd9048b40eaabb115fbf502 SHA512 059f75e3d73563f188e090d75288637471607a41f4d85cf975d25d99f00fd1214a62caaa3d9df30639588e2810d8f4c774502bc14b50a140e1e667186b9f5397
MISC metadata.xml 412 BLAKE2B 0d79131c6fd8adf72493a7c333959e065cf4f2231f6c770800b6d05ff9afcc246cd202406bea6e28f6b0fd23ee6197aa8dac2dd59d0a89d9b07741f57e8fa5e8 SHA512 d1aab9ea8042bf810398a4195fd3595a8abbeb060ab38fd7b7e40085c8d5f22ecb78bab02e2331d4588199d88e0d3848413d75a18fe4373ecd9940a3c990c604
diff --git a/dev-python/pytest-cov/pytest-cov-6.0.0.ebuild b/dev-python/pytest-cov/pytest-cov-6.0.0.ebuild
new file mode 100644
index 000000000000..7a0c80e7d268
--- /dev/null
+++ b/dev-python/pytest-cov/pytest-cov-6.0.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 multiprocessing pypi
+
+DESCRIPTION="pytest plugin for coverage reporting"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-cov
+ https://pypi.org/project/pytest-cov/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/py-1.4.22[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.6[${PYTHON_USEDEP}]
+ >=dev-python/coverage-6.4.4-r1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/fields[${PYTHON_USEDEP}]
+ >=dev-python/process-tests-2.0.2[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.0.0-pytest-xdist-2.5.0.patch
+)
+
+distutils_enable_sphinx docs \
+ dev-python/furo
+distutils_enable_tests pytest
+
+python_test() {
+ # NB: disabling all plugins speeds tests up a lot
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_cov.plugin,xdist.plugin,xdist.looponfail
+
+ local src=$(
+ "${EPYTHON}" -c "import coverage as m; print(*m.__path__)" || die
+ )
+ # TODO: why do we need to do that?!
+ # https://github.com/pytest-dev/pytest-cov/issues/517
+ ln -s "${src}" \
+ "${BUILD_DIR}/install$(python_get_sitedir)/coverage" || die
+
+ nonfatal epytest -n "$(makeopts_jobs)" --dist=worksteal
+ local ret=${?}
+
+ rm "${BUILD_DIR}/install$(python_get_sitedir)/coverage" || die
+
+ [[ ${ret} -ne 0 ]] && die "epytest failed on ${EPYTHON}"
+}