summaryrefslogtreecommitdiff
path: root/dev-python/pytest-cov
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-26 21:10:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-26 21:10:11 +0100
commita20b8556104c163a81183ff983af8123e40f16c5 (patch)
treefc59d7e55cf6c354a7a395587dcfbed577557a84 /dev-python/pytest-cov
parentf3a881e4cb31d574a107320b2f04e2d1f0ddf551 (diff)
gentoo auto-resync : 26:05:2023 - 21:10:11
Diffstat (limited to 'dev-python/pytest-cov')
-rw-r--r--dev-python/pytest-cov/Manifest4
-rw-r--r--dev-python/pytest-cov/pytest-cov-4.0.0-r1.ebuild2
-rw-r--r--dev-python/pytest-cov/pytest-cov-4.1.0.ebuild74
3 files changed, 78 insertions, 2 deletions
diff --git a/dev-python/pytest-cov/Manifest b/dev-python/pytest-cov/Manifest
index 0952a48133ae..e19e0a6b66ed 100644
--- a/dev-python/pytest-cov/Manifest
+++ b/dev-python/pytest-cov/Manifest
@@ -1,4 +1,6 @@
AUX pytest-cov-4.0.0-pytest-xdist-2.5.0.patch 750 BLAKE2B 018b270c47f1c19c19f9d72da935457a6042bcafa580d85f904d082fda9980d9a34579174b7b08551d6cedfbc6a6c7abd7be0216df0e21be64e49efe9d3dd1f5 SHA512 e8826ae013c7fb4cbe57975821faea9a8cfd2573befb4f961560e650cbced56e2dff3e02cde23e29e0bb5d06ce0d5893dc408c9e244ce014a5766c5a565f8efa
DIST pytest-cov-4.0.0.tar.gz 62013 BLAKE2B af8a12955e3f22cd9dc257874f86c04c3c6e29f4af2d2838f37ca196c4955dcf4007c7b404f31c303d0eef6c3735fa1a6268c3bb9f01ed54860750ca2f83b6f5 SHA512 fb993be4d86b29a44e4f2ccd2309d99ab9fe8e6b291abbc2a8a3fc8b36479491165a242a20bfa9886dfd296fcc827da9984b556fdbe9a3ac496ac5b6ba379012
-EBUILD pytest-cov-4.0.0-r1.ebuild 1810 BLAKE2B 188f824ad0283a0e236cdff38ba05bbcb715b8074d2457d1643c512c431001344a59eada8c39158ec3741b7d9487c0d795ed86eb9642a1f90f40be1175acbdb8 SHA512 0d1acdbe117b28054a96c48c69b621f1605a877080247baee50ef4e754a6ea2daec44e2daf3a92ac947005f4e98abca6a5ca027c5d935df287c8c887ce07375c
+DIST pytest-cov-4.1.0.tar.gz 63245 BLAKE2B ed69b96f2117fb924c47b5d80c4e01ec2ab27162ee31a91943e72927a919fe194a8a67ee86eb6bae68ac5a34288c91c57edd8a4800dbffca83f7da4006792d04 SHA512 1280e338ad236ae6757e4538a641fef740bee6c85c5af1f649ba4f28fd99f84ff1048ae40b8633d1751ea248788c1efd401aa078b3aa5929a9249514e5722fc1
+EBUILD pytest-cov-4.0.0-r1.ebuild 1806 BLAKE2B 056688c2708b80fac804712cec99af3f8a2c056d5ec04d33d6ec0d6414a41690e2bac68afd9423a99c65a330ad0110c4630874c42c0b679d8f49ac6eb9b75ef7 SHA512 e6319132e9a9b37eedae468be820448ad3328a8ebd3ef1bc873ff67ed2d80b2bd3d68da1ec6596328b3df4133451d6d520999fb5d75505fe4e2f935503e162f2
+EBUILD pytest-cov-4.1.0.ebuild 2053 BLAKE2B 5f94e747baa127f049559a3fe45107c5fa98a4c8817a37cc1281dbaaecb2d7bbb2daab7b1750c9723dd6bf8364263daea398c8ba2aab88e4ce06cbd2c6c6c4bc SHA512 ede6e9da5c6cfd31e9326ec9b0dd1b89f37940307a50898b4be81ab6fbcf2d644a68050394d4ad74770bc4f582d5752e955c54eab3b8c65c43c456a8d1dc279e
MISC metadata.xml 412 BLAKE2B 0d79131c6fd8adf72493a7c333959e065cf4f2231f6c770800b6d05ff9afcc246cd202406bea6e28f6b0fd23ee6197aa8dac2dd59d0a89d9b07741f57e8fa5e8 SHA512 d1aab9ea8042bf810398a4195fd3595a8abbeb060ab38fd7b7e40085c8d5f22ecb78bab02e2331d4588199d88e0d3848413d75a18fe4373ecd9940a3c990c604
diff --git a/dev-python/pytest-cov/pytest-cov-4.0.0-r1.ebuild b/dev-python/pytest-cov/pytest-cov-4.0.0-r1.ebuild
index 121ae30ad8b7..e78068385cdf 100644
--- a/dev-python/pytest-cov/pytest-cov-4.0.0-r1.ebuild
+++ b/dev-python/pytest-cov/pytest-cov-4.0.0-r1.ebuild
@@ -61,7 +61,7 @@ python_test() {
ln -s "${src}/coverage" \
"${BUILD_DIR}/install$(python_get_sitedir)/coverage" || die
- nonfatal epytest foo
+ nonfatal epytest
local ret=${?}
rm "${BUILD_DIR}/install$(python_get_sitedir)/coverage" || die
diff --git a/dev-python/pytest-cov/pytest-cov-4.1.0.ebuild b/dev-python/pytest-cov/pytest-cov-4.1.0.ebuild
new file mode 100644
index 000000000000..028d25048b4a
--- /dev/null
+++ b/dev-python/pytest-cov/pytest-cov-4.1.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="pytest plugin for coverage reporting"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-cov/
+ https://pypi.org/project/pytest-cov/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/py-1.4.22[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.6[${PYTHON_USEDEP}]
+ >=dev-python/coverage-6.4.4-r1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/fields[${PYTHON_USEDEP}]
+ >=dev-python/process-tests-2.0.2[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.0.0-pytest-xdist-2.5.0.patch
+)
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-py3doc-enhanced-theme
+distutils_enable_tests pytest
+
+python_test() {
+ # NB: disabling all plugins speeds tests up a lot
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_cov.plugin,xdist.plugin,xdist.looponfail
+
+ local EPYTEST_DESELECT=(
+ # attempts to install packages via pip (network)
+ tests/test_pytest_cov.py::test_dist_missing_data
+ # TODO
+ tests/test_pytest_cov.py::test_contexts
+ tests/test_pytest_cov.py::test_cleanup_on_sigterm
+ tests/test_pytest_cov.py::test_cleanup_on_sigterm_sig_dfl
+ tests/test_pytest_cov.py::test_cleanup_on_sigterm_sig_dfl_sigint
+ tests/test_pytest_cov.py::test_cleanup_on_sigterm_sig_ign
+ )
+
+ local src=$(
+ "${EPYTHON}" -c "import coverage as m; print(*m.__path__)" || die
+ )
+ # TODO: why do we need to do that?!
+ # https://github.com/pytest-dev/pytest-cov/issues/517
+ ln -s "${src}/coverage" \
+ "${BUILD_DIR}/install$(python_get_sitedir)/coverage" || die
+
+ nonfatal epytest
+ local ret=${?}
+
+ rm "${BUILD_DIR}/install$(python_get_sitedir)/coverage" || die
+
+ [[ ${ret} -ne 0 ]] && die "epytest failed on ${EPYTHON}"
+}