summaryrefslogtreecommitdiff
path: root/dev-python/pytest-django
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-23 20:53:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-23 20:53:51 +0100
commit3018b5a4bd4777c51e2793818305d7af2409a7fd (patch)
tree614c2151adcf4d5a47d494f83ec3f57d35f8e0a7 /dev-python/pytest-django
parent2508f64d6edae6ffd910973df8285893a791b64a (diff)
gentoo auto-resync : 23:07:2023 - 20:53:51
Diffstat (limited to 'dev-python/pytest-django')
-rw-r--r--dev-python/pytest-django/Manifest1
-rw-r--r--dev-python/pytest-django/pytest-django-4.5.2-r1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/pytest-django/Manifest b/dev-python/pytest-django/Manifest
index 4a0689337327..b98f3051e5d6 100644
--- a/dev-python/pytest-django/Manifest
+++ b/dev-python/pytest-django/Manifest
@@ -1,4 +1,5 @@
AUX pytest-django-4.5.2-pytest-7.patch 1363 BLAKE2B 167e9fe999261fbf39985de8da87e551d08c9e855812bfc3b35c0a8f6c4c64bb99c2dbc9e706714cb20258da30072420841b033fd71e3157a8821a728be8b0c3 SHA512 9e57788693cdbd472d45c6f40190514a90d7b2d067fd8bfa95938ffbd0471bc9855266f2027368f3ae51bc5f03f743fab65b986c830f450bf72a3269ca17f1d1
DIST pytest-django-4.5.2.gh.tar.gz 75429 BLAKE2B 2e8fba037c7618c6dd1c9200c5c44a7b00a13a2d70b4a593a461af3dbc0333b6814ceca16f88a58f1b6aeea2700cac12b589ede702b8eaf023fb3948e0ab8b9a SHA512 09ed5bfe850599e95190d9b15e9383d1249ea575a7b3921744583da6266dd2c8d3eb4f93c8de96d98e1a8e33d1639937470cdc6d11558fcaea57d014dce13500
+EBUILD pytest-django-4.5.2-r1.ebuild 1375 BLAKE2B 0c1f69697cc21f0cc2ae55887e31db8fa1d45ddffcf22df894378dbc61c1f1d8319b1d630f62c21ff61bfd17386b8c23c3e9f08175730ef46684e881312f7b84 SHA512 366600d9f4b547f579d32db17fc0935a3981b9f65375f95d22827b22eb62c9fd51312e6500a8ff0719cd7646076c210747f051b14cc5c3aa647ee71dff3e0c0d
EBUILD pytest-django-4.5.2.ebuild 1312 BLAKE2B 023dd9538ffa86f1d09c7ed4bbdf78eb5a7672e4a3737656f80f6450a0bc5d9838e54061f554572f41f9b2417e81437339d79d1409fba608032f94aa1dcd7550 SHA512 ce0d10507ac358413547456b3a992a993857546241897f782da8f5a27f6b62b4a2ee8734af85af3cec8b638cc822278852e778496208761844ff982fb277a5cd
MISC metadata.xml 405 BLAKE2B 973e3124eed7a497154d1160e5e1350503b2599a3111968329f0b01496ce1eb6b84b76aeddb427478ffd470aa8aee4102e5598b3406b8d2dbd01703cd9adbef8 SHA512 6d7a6a7e084283cd6564be193a43c80f0599c4aa98ad68a98e656f9f1aa7103cd6164acf040c1e71415e28ebe707b013f92bcf4f2f5139ee873ee20408aed150
diff --git a/dev-python/pytest-django/pytest-django-4.5.2-r1.ebuild b/dev-python/pytest-django/pytest-django-4.5.2-r1.ebuild
new file mode 100644
index 000000000000..69f77ff6a7c0
--- /dev/null
+++ b/dev-python/pytest-django/pytest-django-4.5.2-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Django plugin for py.test"
+HOMEPAGE="
+ https://pypi.org/project/pytest-django/
+ https://pytest-django.readthedocs.io/
+ https://github.com/pytest-dev/pytest-django/
+"
+SRC_URI="
+ https://github.com/pytest-dev/pytest-django/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~sparc ~x86"
+SLOT="0"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+ >=dev-python/pytest-5.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-1.11.1[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-pytest-7.patch
+)
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # something else may be loading it
+ tests/test_django_settings_module.py::test_django_not_loaded_without_settings
+ )
+
+ local -x DJANGO_SETTINGS_MODULE
+ local -x PYTHONPATH=${PWD}
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_django.plugin,xdist.plugin
+ for DJANGO_SETTINGS_MODULE in pytest_django_test.settings_sqlite{,_file}; do
+ einfo "Testing ${DJANGO_SETTINGS_MODULE}"
+ epytest tests
+ done
+}