summaryrefslogtreecommitdiff
path: root/dev-python/pytest-django
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-03 12:28:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-03 12:28:20 +0100
commit3f559ef486314f9b3b48d48eb303d6be68463af9 (patch)
tree3b70212f31ce4d000911c001ce13363d0909dfd1 /dev-python/pytest-django
parent20b6ab983b55b022c6e4af317154089e18ad41cb (diff)
gentoo auto-resync : 03:09:2024 - 12:28:20
Diffstat (limited to 'dev-python/pytest-django')
-rw-r--r--dev-python/pytest-django/Manifest2
-rw-r--r--dev-python/pytest-django/pytest-django-4.9.0.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/pytest-django/Manifest b/dev-python/pytest-django/Manifest
index 4e48a2941b54..ea4977de404c 100644
--- a/dev-python/pytest-django/Manifest
+++ b/dev-python/pytest-django/Manifest
@@ -1,3 +1,5 @@
DIST pytest-django-4.8.0.gh.tar.gz 77646 BLAKE2B 206357110066d233c103755cfd6324e8042d9c93442c25db17a13f02132eab60a315856441e26d43a3c493cf72ce39ef51163ccc5368941875e63656bf9122a7 SHA512 8f7ba6b28cc4c0347876beb85247ccd021767811b9122c8cd0fb5d051df4ae76267b27a3fee5c36882a40716bdcbaab43abf71ef8dd61757087b12fd141632aa
+DIST pytest-django-4.9.0.gh.tar.gz 78407 BLAKE2B 0ab7dd12494fdb5c66ceabc67c793f7d970258a1a1b7cd3f7b31b6ee5087436396936a0a1672d77ab3c7e391f00bc63060e137ee9399a52940ebbc2ba25e253e SHA512 ec4cb8e9220cd21d96b72c1f09cfdd023700831ed583fe79d84a85f8d24eeaf3f111580d672950feecad69455078f0c73879f0d73364e74a4577352a4d8a1d4d
EBUILD pytest-django-4.8.0.ebuild 1260 BLAKE2B 7cc4220b42e68843a43cd8bb4400a0b86b6be137dcde9836d6bc0db2d0578ac1c03fa45ad3447b205a78003650b45fed0f6924045e6be1e98eeddd550fd0971a SHA512 3c16f66ac5c2db2ba8e9beef12af48e352b1f65db63a483aee4ad35bc38c63d7067101f7ac33b5bf54b96ad9d2ed6d758e91e4c5e1f39a26b00be331eb205633
+EBUILD pytest-django-4.9.0.ebuild 1266 BLAKE2B 6d9599e51c127b71860591809a3be92c50892c3eb1a15d1adf37ca7cce61b006a74ea74fdd35f2eb0338fa4244f63c714879d0c36cf6023ab8dd417eff6f7c11 SHA512 a65542dafc03dac8436f33d5fa3878244b72f0281b7355599d9cd10481129fbc389d3cfca1a29d8531cb4a2a15abdedc9c540d6ea9fc2d10c100c0f7b272a78d
MISC metadata.xml 405 BLAKE2B 973e3124eed7a497154d1160e5e1350503b2599a3111968329f0b01496ce1eb6b84b76aeddb427478ffd470aa8aee4102e5598b3406b8d2dbd01703cd9adbef8 SHA512 6d7a6a7e084283cd6564be193a43c80f0599c4aa98ad68a98e656f9f1aa7103cd6164acf040c1e71415e28ebe707b013f92bcf4f2f5139ee873ee20408aed150
diff --git a/dev-python/pytest-django/pytest-django-4.9.0.ebuild b/dev-python/pytest-django/pytest-django-4.9.0.ebuild
new file mode 100644
index 000000000000..08cc58692195
--- /dev/null
+++ b/dev-python/pytest-django/pytest-django-4.9.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Django plugin for pytest"
+HOMEPAGE="
+ https://pypi.org/project/pytest-django/
+ https://pytest-django.readthedocs.io/
+ https://github.com/pytest-dev/pytest-django/
+"
+SRC_URI="
+ https://github.com/pytest-dev/pytest-django/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-7.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-1.11.1[${PYTHON_USEDEP}]
+ test? (
+ dev-python/django[${PYTHON_USEDEP}]
+ >=dev-python/django-configurations-2.0[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x DJANGO_SETTINGS_MODULE
+ local -x PYTHONPATH=${PWD}
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_django.plugin,xdist.plugin
+ for DJANGO_SETTINGS_MODULE in pytest_django_test.settings_sqlite{,_file}; do
+ einfo "Testing ${DJANGO_SETTINGS_MODULE}"
+ epytest tests
+ done
+}