summaryrefslogtreecommitdiff
path: root/dev-python/pytest-django
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-python/pytest-django
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-python/pytest-django')
-rw-r--r--dev-python/pytest-django/Manifest2
-rw-r--r--dev-python/pytest-django/pytest-django-4.2.0.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pytest-django/Manifest b/dev-python/pytest-django/Manifest
index c0fcf32699f5..d142aa9a2097 100644
--- a/dev-python/pytest-django/Manifest
+++ b/dev-python/pytest-django/Manifest
@@ -1,3 +1,5 @@
DIST pytest-django-4.1.0.gh.tar.gz 67983 BLAKE2B b7f4fe1366ce1443b19f05e8e834f0555cd8d63bf10921be1427338b7e5e737b7e04d96c9c9d2ad1b9c0f0ed6fba4ed93fb4fd9a948dc5315b4b7a35ba8adfd1 SHA512 734921f5c6f8569f6488706fbb6ca2515a5b24c6641fd260771022bd4fd72b65d062a8130f59163e8b30f4c9bceb383d154b26f8fbf46a1903339668d0a7d12b
+DIST pytest-django-4.2.0.gh.tar.gz 68370 BLAKE2B 94165a01ecd2734a4e02267ecfe8b531df33ca9237cfcd1ebad41f68289fb89590bed0027137d6dddefc4cbbd5c0f8445703e01a516d3992c2307ebe53d6572b SHA512 2dcaa80f3ebb67984d3849cea5de296388990ca65a607f995b89bd67e2d8964f944100bccb42a32bb75c7009849619e50421c2dce077037ce0440233dbdc13f1
EBUILD pytest-django-4.1.0.ebuild 817 BLAKE2B 30eb3c9e830b6d0df6d1d8243b2e658d8a5fb02b892380f91fb50c89622204f430926eb133208d545fb568647dc039a11160aab095ad05cc53fd136aac9587be SHA512 45419bf5309f1b2d4db8f20e2b8033b75c5553dfdb6e1fc79652dcfe3832e32e6b326ae24fb205a272d1ba676f9d033e666cdd6c0376aca95f2be4521e0298ec
+EBUILD pytest-django-4.2.0.ebuild 822 BLAKE2B e9e861b673e839e5262cf9665322d9fe5cf86b67447f725e6ea2ae4c023cde24e59236b0ed4b7bffc25c15b35770bba5c8aca4812e61f9ac0db91990e89a91af SHA512 78f4fa922dc9bc5865adc46b8bfb64ee4b4b584273b8bbbbd3ba5eaffe826c547646b38948de725f28397cd6f97039629e574038f1453c774979a2a1275a3dc5
MISC metadata.xml 404 BLAKE2B 24556c59793b77f5c6de6f5c1210575d7bf7b5dc55aa7427d630d21311a77b31e3c846d5198ebf9b0407a0b1a36eae17bbd37a988c376eda666680871de30ea6 SHA512 33db1ea8ab6490e9b09daf334f48aa8db16db565e264b47b120797aee63c08c99aa27cae3c0a55a21c87552f99ad1ba9a13ba3b53e4562608209efb87a227268
diff --git a/dev-python/pytest-django/pytest-django-4.2.0.ebuild b/dev-python/pytest-django/pytest-django-4.2.0.ebuild
new file mode 100644
index 000000000000..ac4f7fbd41ae
--- /dev/null
+++ b/dev-python/pytest-django/pytest-django-4.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Django plugin for py.test"
+HOMEPAGE="
+ https://pypi.org/project/pytest-django/
+ https://pytest-django.readthedocs.io/
+ https://github.com/pytest-dev/pytest-django/"
+SRC_URI="
+ https://github.com/pytest-dev/pytest-django/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/pytest-5.4[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools_scm-1.11.1[${PYTHON_USEDEP}]
+"
+
+# not all test dependencies are packaged and this package isn't worth it.
+RESTRICT="test"
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}