summaryrefslogtreecommitdiff
path: root/dev-python/pytest-expect
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/pytest-expect
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/pytest-expect')
-rw-r--r--dev-python/pytest-expect/Manifest3
-rw-r--r--dev-python/pytest-expect/metadata.xml11
-rw-r--r--dev-python/pytest-expect/pytest-expect-1.1.0.ebuild21
3 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pytest-expect/Manifest b/dev-python/pytest-expect/Manifest
new file mode 100644
index 000000000000..e5e50049138a
--- /dev/null
+++ b/dev-python/pytest-expect/Manifest
@@ -0,0 +1,3 @@
+DIST pytest-expect-1.1.0.tar.gz 3595 SHA256 36b4462704450798197d090809a05f4e13649d9cba9acdc557ce9517da1fd847 SHA512 41d2b296844e9dab9429f34eec37fe106a4e6c2039824c37067ed048dcc328b13e666b22d3482ccfc6153af4e44b5d895f3011ec45df55ffa07a98459e3caefd WHIRLPOOL b56ca4fb02dc9a844fe12128f09531ba1a199276276f976472e24ca2337990b9b99fac691d6118a714408531d373e25dad23586da43d1ea07cb5821ff0312e93
+EBUILD pytest-expect-1.1.0.ebuild 682 SHA256 812f7cc5e4c45e6c59939251e6c5aac8b63a74de6f26ccffa8303c4d923bd141 SHA512 b9c6a54ca557e5bff774054b3ea3f277de4a2e89c470563f6ea3db9f01a6358f86aa892da9b821667f9a6d746c5408e96362fe02ad53f9d2f248249d61770f4d WHIRLPOOL acbb2e3cd16b2bf28f521c5f5f19e26c5609c36388038a915d8d51e114b7a9bb5f3773a586b2fa938efa8faf17562b0bd8755b91da5d529c8da56866b87c789a
+MISC metadata.xml 357 SHA256 c3a9c50de2a8869ed3931237982cebfaffbe6041c7a46f98a04b19a6fc21480e SHA512 6c6151ca1a141fdbecdb4eae172cf6d21bd41f2827db435f8d1a6a4dd95743fc291f302848b9afad0e1fdb9e7bb8030bf0f8e46a69e8d4ad9ed0d648b1aef870 WHIRLPOOL 9d3e965bfadb717106d6a9674c29c62b94fd22b418502b6130df181e84baf12eb8317602ce1e50158e4fa316ba7301a727c0ee98a2a4abeb0fd156d1e1adbb09
diff --git a/dev-python/pytest-expect/metadata.xml b/dev-python/pytest-expect/metadata.xml
new file mode 100644
index 000000000000..b6e0ef321536
--- /dev/null
+++ b/dev-python/pytest-expect/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="pypi">pytest-expect</remote-id>
+ <remote-id type="github">gsnedders/pytest-expect</remote-id>
+ </upstream>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/pytest-expect/pytest-expect-1.1.0.ebuild b/dev-python/pytest-expect/pytest-expect-1.1.0.ebuild
new file mode 100644
index 000000000000..dd16adc315ca
--- /dev/null
+++ b/dev-python/pytest-expect/pytest-expect-1.1.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin that stores test expectations by saving the set of failing tests"
+HOMEPAGE="https://github.com/gsnedders/pytest-expect/ https://pypi.python.org/pypi/pytest-expect/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/u-msgpack[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"