summaryrefslogtreecommitdiff
path: root/dev-python/pytest-expect
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pytest-expect
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pytest-expect')
-rw-r--r--dev-python/pytest-expect/Manifest3
-rw-r--r--dev-python/pytest-expect/metadata.xml11
-rw-r--r--dev-python/pytest-expect/pytest-expect-1.1.0.ebuild24
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pytest-expect/Manifest b/dev-python/pytest-expect/Manifest
new file mode 100644
index 000000000000..44cbc9711b9d
--- /dev/null
+++ b/dev-python/pytest-expect/Manifest
@@ -0,0 +1,3 @@
+DIST pytest-expect-1.1.0.tar.gz 3595 BLAKE2B f291021c1fb44371f43d5970573872d3db04e0b29e909de01c2183e79d96f9a72060b75f914cd7460b914864b98191460b4c44809a0f5ddf728fc6ef0c94c348 SHA512 41d2b296844e9dab9429f34eec37fe106a4e6c2039824c37067ed048dcc328b13e666b22d3482ccfc6153af4e44b5d895f3011ec45df55ffa07a98459e3caefd
+EBUILD pytest-expect-1.1.0.ebuild 704 BLAKE2B 67625c57bc3f522f950473f274836a0e09d74582756b76847407c2a0ac97909554d1a511b67ba8d1167299255ccb85dc235aef54ce1399e1f67b8817dd270838 SHA512 46da9def6c4eb3fc11de441753f836dd99707341e13ab118c42f330c93b5a2096b39e47bb353e24b9db14b671e13ccb0a1c218d831357c0107ca54d08d0a75ab
+MISC metadata.xml 357 BLAKE2B 29b8df313fa5bb9f7666ba95df518d3ada2f9bf783c2e14cde2f404cf10504e5631ad2a512303acfdd0a4ffdad845fe482082d5234e6b54818f38c83c07391f9 SHA512 6c6151ca1a141fdbecdb4eae172cf6d21bd41f2827db435f8d1a6a4dd95743fc291f302848b9afad0e1fdb9e7bb8030bf0f8e46a69e8d4ad9ed0d648b1aef870
diff --git a/dev-python/pytest-expect/metadata.xml b/dev-python/pytest-expect/metadata.xml
new file mode 100644
index 000000000000..b6e0ef321536
--- /dev/null
+++ b/dev-python/pytest-expect/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="pypi">pytest-expect</remote-id>
+ <remote-id type="github">gsnedders/pytest-expect</remote-id>
+ </upstream>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/pytest-expect/pytest-expect-1.1.0.ebuild b/dev-python/pytest-expect/pytest-expect-1.1.0.ebuild
new file mode 100644
index 000000000000..601781104143
--- /dev/null
+++ b/dev-python/pytest-expect/pytest-expect-1.1.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin that stores test expectations by saving the set of failing tests"
+HOMEPAGE="https://github.com/gsnedders/pytest-expect/ https://pypi.org/project/pytest-expect/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm arm64 hppa ia64 ~mips ~ppc ~ppc64 sparc x86 ~amd64-fbsd"
+IUSE=""
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/u-msgpack[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"