summaryrefslogtreecommitdiff
path: root/dev-python/pytest-flake8
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/pytest-flake8
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/pytest-flake8')
-rw-r--r--dev-python/pytest-flake8/Manifest2
-rw-r--r--dev-python/pytest-flake8/pytest-flake8-1.0.7.ebuild12
2 files changed, 10 insertions, 4 deletions
diff --git a/dev-python/pytest-flake8/Manifest b/dev-python/pytest-flake8/Manifest
index 0ee70d7b57b5..d4054b957719 100644
--- a/dev-python/pytest-flake8/Manifest
+++ b/dev-python/pytest-flake8/Manifest
@@ -1,3 +1,3 @@
DIST pytest-flake8-1.0.7.tar.gz 9560 BLAKE2B 056066a6693fa6988448662e52856eeed49688e834b344e5f60f31f1c3b3ef89043dba06bddbf958b042ab9e702fec056784b252e96c8b4b46fe350a801535cf SHA512 16e7b437ff9fc9afd3520f6b81d9eafeda840c7cd7925f5287ce0e0d5b20a0fa758183cea7ade369e3fec8606eee976e84c5b3142923e4586f559232012bf3a3
-EBUILD pytest-flake8-1.0.7.ebuild 524 BLAKE2B 5c485a9911f7a14bc8de422d6406b5f44e3c5b7085af8ff80ea24b4edd2abce8c7b610c87f929b74c74d322d5cf146bb8317467b2590de675c9f9391bc4c4599 SHA512 941eddca1aee9da99bb0b23f7edb18d10e6aa5ea3c222a45873ec6332f5f38741f84efd80c87c37f5dbb9a6021b3c26221947df4907067cc2efd47fe0425a41d
+EBUILD pytest-flake8-1.0.7.ebuild 566 BLAKE2B cb8a5bd070e1266a7a64a7d996b8be872953f8b4830b984e6377dd82f98347eee7fe67c2279889f6822f3c73b5971b4662ebe69fc6fdf771f4d81434fb6d3c48 SHA512 9a3ec43b0cd77d7940372827252d43bd33669d5eac240f2fce74d09c51d9e5f65f752a754502b1a2de97edb70d4c0a2332320ceb5ca7de36ffa5c87b0ba8c9b2
MISC metadata.xml 533 BLAKE2B f5c41488f4252fbe9e61d38c3441f90eeda799092f7b4a42a6a87285a69141f9d56ed614d7e21df6cf5017d92464657976936106c2de5581db71b244e2a361fd SHA512 979159321b69d9ffe9ebc7a30b51c613a8d113b897b14b781ff71772769067b3fc3af37066cfd4d00542f5fe71e0b1a50a8c1028d36100538ead09c4f3d9859f
diff --git a/dev-python/pytest-flake8/pytest-flake8-1.0.7.ebuild b/dev-python/pytest-flake8/pytest-flake8-1.0.7.ebuild
index 6398ac03bfb8..29d153438360 100644
--- a/dev-python/pytest-flake8/pytest-flake8-1.0.7.ebuild
+++ b/dev-python/pytest-flake8/pytest-flake8-1.0.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -6,8 +6,10 @@ EAPI=7
PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
-DESCRIPTION="py.test plugin for flake8"
-HOMEPAGE="https://github.com/tholo/pytest-flake8 https://pypi.org/project/pytest-flake8"
+DESCRIPTION="pytest plugin for flake8"
+HOMEPAGE="
+ https://github.com/tholo/pytest-flake8/
+ https://pypi.org/project/pytest-flake8/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
@@ -17,3 +19,7 @@ KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 x86"
RDEPEND=">=dev-python/flake8-3.5.0[${PYTHON_USEDEP}]"
distutils_enable_tests pytest
+
+python_test() {
+ epytest -p flake8
+}