summaryrefslogtreecommitdiff
path: root/dev-python/pytest-flakes
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-02-10 15:40:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-02-10 15:40:27 +0000
commit6bc2e4d7c5906e46a8f275a876ead6ec41aca5bb (patch)
treecee0a97398040001220ece3cd48c3d568bcddb4a /dev-python/pytest-flakes
parent1db00cc6e94b90c08090bb5b8c406622946c4ae5 (diff)
gentoo resync : 10.02.2019
Diffstat (limited to 'dev-python/pytest-flakes')
-rw-r--r--dev-python/pytest-flakes/Manifest3
-rw-r--r--dev-python/pytest-flakes/metadata.xml12
-rw-r--r--dev-python/pytest-flakes/pytest-flakes-4.0.0.ebuild24
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pytest-flakes/Manifest b/dev-python/pytest-flakes/Manifest
new file mode 100644
index 000000000000..41c81d4039dd
--- /dev/null
+++ b/dev-python/pytest-flakes/Manifest
@@ -0,0 +1,3 @@
+DIST pytest-flakes-4.0.0.tar.gz 7138 BLAKE2B e3c43df60484c664672f8b9ea92f8d4e25ae33e0dffc9cee200867220a3c8840f7325be28a4bec44918a9b44c1d73d3b89517db8dfa9bb982ed92a34c3b09674 SHA512 e74fe78e713040e3e85f206e8d26f5b8d8ef27dd94c2afccf3cd0f1f982c5e6c30c5966f2cdb774c7a2a8052d1a5cb324626b1997a9e75f5a7bb7d4a5e99376a
+EBUILD pytest-flakes-4.0.0.ebuild 607 BLAKE2B 4c79f1c8d6296748f930b488b6ca9569dee63ad9928a72a152bdabc1db153f42b15f7a577d20e017f710d541a43595b3339eb37e29b14f4a55cdd7c87891ece3 SHA512 760542a57e4159d0edd7e6f1c63de73c94e9512af3554e6b142c303d5109f7ec01dc657f50b37ce71e10ce8982d2d2ddc77ce77bdec413693518e719be26c5a0
+MISC metadata.xml 322 BLAKE2B 4f4573205a169edb1b0883546480cf852d1eb0a9b5f99c7326a55e4f6002345c06961d8394e7de26d13616ec78f8744cfbb122964b40ce5215920749f92bdcc5 SHA512 129a0bb37ba1cd528848d3c537a7a776b7526eded473f97e986307a9a185b4337d60f6f5f0ed1beac1d0f18fee6d9023753b9cb89d77e3b3a06576104701273a
diff --git a/dev-python/pytest-flakes/metadata.xml b/dev-python/pytest-flakes/metadata.xml
new file mode 100644
index 000000000000..9d43655030c4
--- /dev/null
+++ b/dev-python/pytest-flakes/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chainsaw@gentoo.org</email>
+ <name>Tony Vroon</name>
+ </maintainer>
+
+ <upstream>
+ <remote-id type="pypi">pytest-flakes</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-flakes/pytest-flakes-4.0.0.ebuild b/dev-python/pytest-flakes/pytest-flakes-4.0.0.ebuild
new file mode 100644
index 000000000000..976094bbe3ae
--- /dev/null
+++ b/dev-python/pytest-flakes/pytest-flakes-4.0.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3)
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of small Python functions & classes"
+HOMEPAGE="https://pypi.org/project/python-utils/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}"
+
+python_test() {
+ "${PYTHON}" ./test_flakes.py || die "Tests failed under ${EPYTHON}"
+}