summaryrefslogtreecommitdiff
path: root/dev-python/pytest-flask
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-18 06:30:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-18 06:30:11 +0000
commitf57e008aa126ccdca95f7424e4d24a1a83a49682 (patch)
tree485fb1d76c7c51ddd47615c50059dd46045ffbb5 /dev-python/pytest-flask
parent066666b8767b78231b90d9b3ffc8169fbfe1ec7c (diff)
gentoo auto-resync : 18:12:2024 - 06:30:11
Diffstat (limited to 'dev-python/pytest-flask')
-rw-r--r--dev-python/pytest-flask/Manifest3
-rw-r--r--dev-python/pytest-flask/metadata.xml24
-rw-r--r--dev-python/pytest-flask/pytest-flask-1.3.0.ebuild27
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/pytest-flask/Manifest b/dev-python/pytest-flask/Manifest
new file mode 100644
index 000000000000..a750782ce412
--- /dev/null
+++ b/dev-python/pytest-flask/Manifest
@@ -0,0 +1,3 @@
+DIST pytest-flask-1.3.0.tar.gz 35816 BLAKE2B 008c7f2acdc320dcab3e1745fb8e546a1f4cbdf75155db85f00bb70aea2eb3efa46d68f39fac114e3ddc3675b45d3d6d9a7bba8eb0c331c36e7f3d08c83c5da0 SHA512 4512e261cf6b284540ea9dda4cade52be57776c16f0cc7185755cbec294e526268753dbe663200a6ab3dee2ac0cc42df080d8f0045f88feac5de115fcc71ac21
+EBUILD pytest-flask-1.3.0.ebuild 594 BLAKE2B e4ee43c09ad6236c20de892ec990f4813aad2e8b881d754a83464cabeec9989634fe29673405807ae7e10b741d525d0fe4c69333edbad12cb02c82bf9626bf16 SHA512 a6835ec572fd2b3d1336bca21d87462b01cec75c781c202fb7ea0482c1a5b1ea2d717c898816912b8ee5d7137ee24d29e4974d6e76e4990aec2e55568003eb3f
+MISC metadata.xml 759 BLAKE2B d25593bb8debad03c313b3ca441b60f38ea495757af12c9348d25e14bfbca037c4dfabda81f2f9a685796f507bc3a81f10597fa61ab4c17ae4448862c244137c SHA512 bd1b0c859978aa5705aa69dcaee06904f55bdb5fe29a17702653ff6b289ef891e6e0467e95fb54d1e613fd1dcf210b154a4c77a292a70cc1f18ded737a420871
diff --git a/dev-python/pytest-flask/metadata.xml b/dev-python/pytest-flask/metadata.xml
new file mode 100644
index 000000000000..ec950627c5ed
--- /dev/null
+++ b/dev-python/pytest-flask/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>arsen@gentoo.org</email>
+ <description>Arsen Arsenović</description>
+ </maintainer>
+ <maintainer type="person" proxied="yes">
+ <email>davidroman96@gmail.com</email>
+ <name>David Roman</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pytest-flask</remote-id>
+ <remote-id type="github">pytest-dev/pytest-flask</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-flask/pytest-flask-1.3.0.ebuild b/dev-python/pytest-flask/pytest-flask-1.3.0.ebuild
new file mode 100644
index 000000000000..b8519593d805
--- /dev/null
+++ b/dev-python/pytest-flask/pytest-flask-1.3.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{11..13} pypy3 )
+inherit distutils-r1 pypi
+
+DESCRIPTION="A set of pytest fixtures to test Flask applications"
+HOMEPAGE="
+ http://pytest-flask.readthedocs.org
+ https://github.com/pytest-dev/pytest-flask
+ https://pypi.org/project/pytest-flask/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest