summaryrefslogtreecommitdiff
path: root/dev-python/pytest-forked
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /dev-python/pytest-forked
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'dev-python/pytest-forked')
-rw-r--r--dev-python/pytest-forked/Manifest4
-rw-r--r--dev-python/pytest-forked/pytest-forked-1.3.0-r1.ebuild35
-rw-r--r--dev-python/pytest-forked/pytest-forked-1.4.0.ebuild4
3 files changed, 3 insertions, 40 deletions
diff --git a/dev-python/pytest-forked/Manifest b/dev-python/pytest-forked/Manifest
index f608643de557..69a6bfbe590d 100644
--- a/dev-python/pytest-forked/Manifest
+++ b/dev-python/pytest-forked/Manifest
@@ -1,5 +1,3 @@
-DIST pytest-forked-1.3.0.tar.gz 9850 BLAKE2B cbe44d87052c5a3bc58934ac17153401810004aaa38b53ff3100384535cb2ea0fa99dada706113f324fa0a135ddbd9b97488319b4a9554d912388c341b62943c SHA512 25d639aa43380155d7744f1d05a95e0144f5fe7dea42ff3c2bba3803a07d73b5eb008525469330c5dda14800fe4b611241691be197132f31f88f66930c3ecac0
DIST pytest-forked-1.4.0.tar.gz 10197 BLAKE2B 7a6ec42f7ad1323eea243739a9186fb87eac3016afef844ec39a6e3fd55f7d40b1410fcc27074624f8468e6dabddffcc22ea0597bbbd898fab71c82c06e25b46 SHA512 ba402aec6dbec7a94815913192a49390b637a123d3557f48d809ae2e871e9e0cff8f9d0feb99e2bd06fe9486520b5e539f397d39475a720f8283b1bd21c751c7
-EBUILD pytest-forked-1.3.0-r1.ebuild 935 BLAKE2B 55fa6f0134ca91c17164c797b60f9742ca28b8d93d15af25a2c8a7239f78e44f22edcd4949d06a5fee5c227be9051ac8a7c895c433e1ea4ced1d35bf2c87bc84 SHA512 5bed1117b5d7575785d36e13e2a51e5d89d531cc3eccef7ed99b804e821b477c1479dc2aca51a37613cf2ead610dcbfe3579dbdfc37547ac68cd1a9a32a87a88
-EBUILD pytest-forked-1.4.0.ebuild 860 BLAKE2B afbf7a639e559b6a680ed30f9d9d593e83a4f8fd94328d1642f8dea3b4acb85c8ff6364789bec6a825f0546e283cf21aa51a7f06ccced272bc28cd43d92f654d SHA512 747de247c4f72720419c7294b59f552fb06893dff1392b1a22b5e6bac34b7cefbaf7b13538835c8a92826cb38d98e8bccfd5a793366d0eda76b6a68c3d8e65d3
+EBUILD pytest-forked-1.4.0.ebuild 852 BLAKE2B 770a1d2950c06fd6cb6ad6596df0f9558b1b853053e0eeddc3b926b3452fb8d87b4bb6078ae52e054cdfab25cb65f26424a713d0b636c7adb9eac4d9d6c3d882 SHA512 fcd0e427a1342120c83b2fd96977cf2ca3d6ed2e23bdc381f49d5183ca20bdd980555a4e74a48bbfcacb2fe9eb66fea6a3ff9a035aaa1885d2649db2a5616e8f
MISC metadata.xml 405 BLAKE2B 8cb6b3e3b440bc53f5d02a9638b00356f64bc02a8d7444ec5e295fcf91507f94c2460acd02008e6b11ca3bc2dd3d2f96ffb61c583fade0ff4ca00a182c01f903 SHA512 4a1dda1d8ada98b57881884ec6e982c308b54ab29e2cfa104f398876a1bd8ee2015dc7de4891c305f65030e30259079667d42c7a80d14d5148feeb5b7cf5904f
diff --git a/dev-python/pytest-forked/pytest-forked-1.3.0-r1.ebuild b/dev-python/pytest-forked/pytest-forked-1.3.0-r1.ebuild
deleted file mode 100644
index 1047da546dfa..000000000000
--- a/dev-python/pytest-forked/pytest-forked-1.3.0-r1.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="run tests in isolated forked subprocesses"
-HOMEPAGE="https://pypi.org/project/pytest-forked/ https://github.com/pytest-dev/pytest-forked"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-# Please do not RDEPEND on pytest; this package won't do anything
-# without pytest installed, and there is no reason to force older
-# implementations on pytest.
-RDEPEND="
- dev-python/py[${PYTHON_USEDEP}]"
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- >=dev-python/pytest-3.10[${PYTHON_USEDEP}]
- )"
-
-python_test() {
- distutils_install_for_testing
- epytest -p no:flaky
-}
diff --git a/dev-python/pytest-forked/pytest-forked-1.4.0.ebuild b/dev-python/pytest-forked/pytest-forked-1.4.0.ebuild
index c65d14f14759..0a182595e8c9 100644
--- a/dev-python/pytest-forked/pytest-forked-1.4.0.ebuild
+++ b/dev-python/pytest-forked/pytest-forked-1.4.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -12,7 +12,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
SLOT="0"
LICENSE="MIT"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
# Please do not RDEPEND on pytest; this package won't do anything
# without pytest installed, and there is no reason to force older