summaryrefslogtreecommitdiff
path: root/dev-python/pytest-golden
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-23 20:53:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-23 20:53:51 +0100
commit3018b5a4bd4777c51e2793818305d7af2409a7fd (patch)
tree614c2151adcf4d5a47d494f83ec3f57d35f8e0a7 /dev-python/pytest-golden
parent2508f64d6edae6ffd910973df8285893a791b64a (diff)
gentoo auto-resync : 23:07:2023 - 20:53:51
Diffstat (limited to 'dev-python/pytest-golden')
-rw-r--r--dev-python/pytest-golden/Manifest2
-rw-r--r--dev-python/pytest-golden/pytest-golden-0.2.2-r1.ebuild (renamed from dev-python/pytest-golden/pytest-golden-0.2.2.ebuild)21
2 files changed, 19 insertions, 4 deletions
diff --git a/dev-python/pytest-golden/Manifest b/dev-python/pytest-golden/Manifest
index a9e068183c14..48b23f8aef80 100644
--- a/dev-python/pytest-golden/Manifest
+++ b/dev-python/pytest-golden/Manifest
@@ -1,3 +1,3 @@
DIST pytest-golden-0.2.2.gh.tar.gz 11928 BLAKE2B efe7af645d643f265c629f8b7f96298554c68f0c91f27e99fa65b520986d60e8ac95bcbfb631f390b0734e6892a041ea7c89c0b12e0c8c9a652bd4af0e107e81 SHA512 77c4395949eaf58f29999f3f68a7bac2a644a6404a02efcf628a35270f6c03b45550391357fad1208fb13ea3dc7d33704346984c821f1a6663cb715d240384b7
-EBUILD pytest-golden-0.2.2.ebuild 833 BLAKE2B 086dd95e90594a3a77749f5e236601e6bcd66b7ca8ec9fd111b88e0d20aa92b3cafda42765e1b5a6dac020a0e6de6b042df3e43b1ea15a9aa98b6aa4bbda5560 SHA512 3d59908fde93b3fb1633d403de895e7ec44fbfdd64783a31c71d21f3fe3c07b1dfc6b2c01c1306e7c979724477ff25b5be1a0e6296df2aab8aa836089042fa13
+EBUILD pytest-golden-0.2.2-r1.ebuild 1062 BLAKE2B 1f849ac51c5e2139fdce1fddd639c95314c2071ec5cb6579ea50f245601163cd8d23e4a5b12ba154d325628f1be05394de53c06f17d43f7befdac8324afa5078 SHA512 7afb87c53e79e14f49cdb669cb7958fda567ab4bf3afedbcefde0af7d75e8c815d006a71b03645bfa4baa183aa933f8f3ee696017bb8146771c67570eca8e3b8
MISC metadata.xml 407 BLAKE2B 0b8198b9ceccea7232bb4caf8baa1f52939306e877b7c3679a0d800f857c76b9c31ef55b1828db6c76d6a03b91b8196dad1de35cf6bcef0d9db42b8619be772a SHA512 a28361422eb426f62d1323e89760aa7623ca885a3252dabe4911fdb68fc9aef5a0e21bf1ad8545c9c7dad3da7c50b7eba36e3b5a91465f305cea88c3f236b921
diff --git a/dev-python/pytest-golden/pytest-golden-0.2.2.ebuild b/dev-python/pytest-golden/pytest-golden-0.2.2-r1.ebuild
index 3087ff87091d..e4f8e404860f 100644
--- a/dev-python/pytest-golden/pytest-golden-0.2.2.ebuild
+++ b/dev-python/pytest-golden/pytest-golden-0.2.2-r1.ebuild
@@ -4,17 +4,20 @@
EAPI=8
DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
DESCRIPTION="Plugin for pytest that offloads expected outputs to data files"
HOMEPAGE="
- https://github.com/oprypin/pytest-golden
+ https://github.com/oprypin/pytest-golden/
https://pypi.org/project/pytest-golden/
"
# No tests in PyPI tarballs
-SRC_URI="https://github.com/oprypin/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+SRC_URI="
+ https://github.com/oprypin/pytest-golden/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
LICENSE="MIT"
SLOT="0"
@@ -29,3 +32,15 @@ RDEPEND="
"
distutils_enable_tests pytest
+
+src_prepare() {
+ # poetry, sigh
+ sed -i -e 's:\^:>=:' pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_golden.plugin
+ epytest -x
+}