summaryrefslogtreecommitdiff
path: root/dev-python/pytest-home
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
commitb8c7370a682e4e29cda623222d17a790c01c3642 (patch)
treef6caa14689bd00a5760eadaa381ff41e50ef3c1b /dev-python/pytest-home
parent8a4997a7e2d1e36c089d4d76935b5a902d98d3d0 (diff)
gentoo auto-resync : 07:08:2024 - 12:37:20
Diffstat (limited to 'dev-python/pytest-home')
-rw-r--r--dev-python/pytest-home/Manifest2
-rw-r--r--dev-python/pytest-home/pytest-home-0.6.0.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pytest-home/Manifest b/dev-python/pytest-home/Manifest
index 8e65dbecd530..8e7d89813a4a 100644
--- a/dev-python/pytest-home/Manifest
+++ b/dev-python/pytest-home/Manifest
@@ -1,3 +1,5 @@
DIST pytest-home-0.5.1.tar.gz 7596 BLAKE2B 3e0ac21a35bff15e652d710bab0c59855c9beda9a1aa32ca5e3aa9e659dabb5a09bc0e93c56f280e859a1d50159f6e56aaf69ec64ee5268a1a93871bca3b3a23 SHA512 6b3ab71f48135d7fe3e0279de598e8067bfeb1f3295d4ab947ff703e8c8c6b61d827ce30f86da15b854a09b813105e459eed02af19da22debd25df20759759b8
+DIST pytest_home-0.6.0.tar.gz 8073 BLAKE2B 13760c97f2466eaf4d6b4cd5630bc7c1129d86049a9083b13fa389a8c8e47de62e2b7b71bafd6348cf6fde8a246b9fe32be6c03d45b7f0bcdef565a95b95fae6 SHA512 8abb4d3f5ff9c5b90ed5cea3b80c877899c68a53d424cc6785a5664b7df1fa7afcaf435c3f752ee74d911dc7ceb4c95e970d25dfad9225538737779ad0b9bcf8
EBUILD pytest-home-0.5.1.ebuild 599 BLAKE2B d2ed6b4b169714bd1fcaf3809eb26128e5957a4b910d1fdbd6c1c7267802bb2b8f25d106c7665a8761cd314bc7d12d19b211db3232d521b42fefdc5d0769530e SHA512 0951eea6ab1cd2f697746a5c09058e7fd8ae039189dce6f27d9022bdf101194fe2b845d1036064efb82a94bedd123c5273455c2329ea7885a898e7ac9ffde914
+EBUILD pytest-home-0.6.0.ebuild 704 BLAKE2B 8c8287cfd45dde7ab0102d95fa1ced2aabf47b9d1df81967fe3ab74d56b1ef7f0fbad5cddf7eee6a512cab39c79f84f2fbf5746a1bb63ee861fccc2dca010763 SHA512 4d1e944cd2cb00fa0e24e2cfc491df4c10dcac5d753960ec4c4e7cb1993283f90ac410a7c96d14ed1fb5fde65a9b93e42a3fbf2ef0aae6ac0740261d91f100ca
MISC metadata.xml 428 BLAKE2B 9f9c0d72ec25e6f573f42709148169aa569a5862a16a43fd443f098ead7e84b621294f70222b0a69fb77d15ff2d98a2ad9418be11deb63f80d1bf83d92139e3c SHA512 be336bb81c2212038016fc5b7f5fc507ebf67e399048008472872450a4bea37e70a1242c62efad674366f2a9933b052c323cea5a1e4bd5c310bde1e50d583a4e
diff --git a/dev-python/pytest-home/pytest-home-0.6.0.ebuild b/dev-python/pytest-home/pytest-home-0.6.0.ebuild
new file mode 100644
index 000000000000..9b96b2c5bf9c
--- /dev/null
+++ b/dev-python/pytest-home/pytest-home-0.6.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Home directory fixtures"
+HOMEPAGE="
+ https://github.com/jaraco/pytest-home/
+ https://pypi.org/project/pytest-home/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_home.fixtures
+ epytest
+}