summaryrefslogtreecommitdiff
path: root/dev-python/pytest-httpbin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-23 21:00:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-23 21:00:11 +0100
commit456fc832c996a122c45240beb68820ab3c2ada40 (patch)
tree947c249e75095705ddfd9e3dbb77e7b0b47bf915 /dev-python/pytest-httpbin
parent764cacf515464f89b60c94a29b3b7262479feb22 (diff)
gentoo auto-resync : 23:05:2023 - 21:00:10
Diffstat (limited to 'dev-python/pytest-httpbin')
-rw-r--r--dev-python/pytest-httpbin/Manifest3
-rw-r--r--dev-python/pytest-httpbin/files/pytest-httpbin-1.0.0-pypy3-hang.patch31
-rw-r--r--dev-python/pytest-httpbin/pytest-httpbin-1.0.2.ebuild43
3 files changed, 0 insertions, 77 deletions
diff --git a/dev-python/pytest-httpbin/Manifest b/dev-python/pytest-httpbin/Manifest
index efeeb6a2f468..c732bfb0600f 100644
--- a/dev-python/pytest-httpbin/Manifest
+++ b/dev-python/pytest-httpbin/Manifest
@@ -1,6 +1,3 @@
-AUX pytest-httpbin-1.0.0-pypy3-hang.patch 1099 BLAKE2B 4bb8dd686aadc35aab144a6467d52e7de675bcc7d6de8f130bc5942c17fd19c0c914d9aef81af3ed0a815ce21caf40ad8e7c8f724710fe07290dcc8fb92d6a24 SHA512 b0f417e7fdf658783e9297a895f50587d7b997de5065f5322fb46644028caa7cd10cf6130c578f6dd1f8b6aefbd281342f6aa8f5477284de3d4037b799604f72
-DIST pytest-httpbin-1.0.2.gh.tar.gz 18727 BLAKE2B 56a7fa1c1694cad98815fc6c6f676b509942fa1fca192ecb4cb5a0d9f325d7df6ddb3a3ac67d884c8f8caba807677351c42c28a3bcba80b9196e74d666951cc2 SHA512 b4adac1c37506391d83f7772814b4a9ce5134cc6834d8758e71d39610f8b29e57e72b11b2233be51e41b2c36bc305d40fc4b260a7f83d10390f4e940df8aa366
DIST pytest-httpbin-2.0.0.gh.tar.gz 19799 BLAKE2B 7725bc958417c076ee920abce83bdad8295bc4c9551500040867650d54c306e79a1ea92b013124b793058103fc9685dbb2202be5f1b2da935509f68457d63d68 SHA512 62876590bacae6601739f5cc2eccb087024e16731afc9613b5e6928c2a2f64b73418ddcb3c4f13a4bfe1f074510f922d85411d05ebf66f123a4a09d535771b64
-EBUILD pytest-httpbin-1.0.2.ebuild 975 BLAKE2B c434e860cb624e1dbe8cb741d5c521f446061789414a82db840a37225264c0aebc27cd6d14949a0472e4b983809f0d74241196ca6c3852efe5e9bde66aef0328 SHA512 cf100b126bb54255d39d951931a80e4926d657875cc1487988b6063b374b758ce54b3afefc5f23f1da51f24fedf9c57164af65cddb006aa074cfcfd798a76141
EBUILD pytest-httpbin-2.0.0.ebuild 1037 BLAKE2B a05c816cd23b3a34ae4b4c49a1fdfb69ae62199661f3382fb03d9abe7ab52e169622b6fa76f2439d1b82398a1abec0d985ed9ac2422f0b64ed3bb51e6379183d SHA512 803089e64ae62ad8731c0aaef3dc87f1a78f8595835e0267c82da93ed79fe4228f47a78609770fa96412af0f2d7aa0e1f866d329f9a177887e474115ab8adbd8
MISC metadata.xml 547 BLAKE2B d60e6b3e6c7d0c37dcc42dcffeed9e08fb7ad3dec5e4f5fdc0ffd1f7a2c46d89ef57a9576028457ee433d0ecbd100ae200ef507b22bb326838732751a7c644fc SHA512 4629dfe7e4cf27d5d52e7ce3e646f590b4d80a490c638cb035352416a587b494328d3f23e088d13ae1677c415080a7249301d9830be0cfbce7a44023302bf582
diff --git a/dev-python/pytest-httpbin/files/pytest-httpbin-1.0.0-pypy3-hang.patch b/dev-python/pytest-httpbin/files/pytest-httpbin-1.0.0-pypy3-hang.patch
deleted file mode 100644
index 02f63bffa72d..000000000000
--- a/dev-python/pytest-httpbin/files/pytest-httpbin-1.0.0-pypy3-hang.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-diff -dupr a/pytest_httpbin/serve.py b/pytest_httpbin/serve.py
---- a/pytest_httpbin/serve.py 2019-02-11 20:54:14.000000000 +0100
-+++ b/pytest_httpbin/serve.py 2019-11-22 15:50:17.407769297 +0100
-@@ -116,6 +116,7 @@ class Server(object):
-
- def stop(self):
- self._server.shutdown()
-+ self._server.socket.close()
-
- @property
- def url(self):
-Only in b: pytest_httpbin.egg-info
-Only in b/tests: __pycache__
-diff -dupr a/tests/test_httpbin.py b/tests/test_httpbin.py
---- a/tests/test_httpbin.py 2019-02-11 20:54:14.000000000 +0100
-+++ b/tests/test_httpbin.py 2019-11-22 15:59:53.955324547 +0100
-@@ -1,3 +1,4 @@
-+import sys
- import unittest
- import requests
- import pytest_httpbin
-@@ -40,6 +41,8 @@ def test_httpbin_join(httpbin):
- def test_httpbin_str(httpbin):
- assert httpbin + '/foo' == httpbin.url + '/foo'
-
-+@unittest.skipIf(hasattr(sys, 'pypy_version_info')
-+ and sys.hexversion >= 0x03000000, 'hangs on PyPy3')
- def test_chunked_encoding(httpbin_both):
- assert requests.get(httpbin_both.url + '/stream/20').status_code == 200
-
-Only in b: .tox
diff --git a/dev-python/pytest-httpbin/pytest-httpbin-1.0.2.ebuild b/dev-python/pytest-httpbin/pytest-httpbin-1.0.2.ebuild
deleted file mode 100644
index ef92b210fea8..000000000000
--- a/dev-python/pytest-httpbin/pytest-httpbin-1.0.2.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Easily test your HTTP library against a local copy of httpbin"
-HOMEPAGE="
- https://github.com/kevin1024/pytest-httpbin/
- https://pypi.org/project/pytest-httpbin/
-"
-SRC_URI="
- https://github.com/kevin1024/pytest-httpbin/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
-
-RDEPEND="
- dev-python/httpbin[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/requests[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/pytest-httpbin-1.0.0-pypy3-hang.patch
-)
-
-EPYTEST_DESELECT=(
- tests/test_server.py::test_redirect_location_is_https_for_secure_server
-)
-
-distutils_enable_tests pytest