summaryrefslogtreecommitdiff
path: root/dev-python/pytest-httpx/pytest-httpx-0.23.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-03 10:53:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-03 10:53:03 +0100
commit58bc1eef7fcc2712f4fe69e418f697d6f4d57df4 (patch)
treed8f8ac35082dce2ae2d058c2a9206b36c941bcd7 /dev-python/pytest-httpx/pytest-httpx-0.23.1.ebuild
parentcde8c93952da8c35584929e3778914d821cd6800 (diff)
gentoo auto-resync : 03:08:2023 - 10:53:03
Diffstat (limited to 'dev-python/pytest-httpx/pytest-httpx-0.23.1.ebuild')
-rw-r--r--dev-python/pytest-httpx/pytest-httpx-0.23.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pytest-httpx/pytest-httpx-0.23.1.ebuild b/dev-python/pytest-httpx/pytest-httpx-0.23.1.ebuild
new file mode 100644
index 000000000000..336dab68638d
--- /dev/null
+++ b/dev-python/pytest-httpx/pytest-httpx-0.23.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Send responses to HTTPX using pytest"
+HOMEPAGE="
+ https://colin-b.github.io/pytest_httpx/
+ https://github.com/Colin-b/pytest_httpx/
+ https://pypi.org/project/pytest-httpx/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-python/httpx-0.24*[${PYTHON_USEDEP}]
+ <dev-python/pytest-8[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest