summaryrefslogtreecommitdiff
path: root/dev-python/pytest-httpx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-21 12:11:53 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-21 12:11:53 +0100
commit1fd1215c62ee14dc2e94fa04d6e3622391c9ab57 (patch)
tree909630a900b1ac6b180d8af2e2345a171417d59f /dev-python/pytest-httpx
parentd60aa36cd97fb2193f756b45820d7c073a49229d (diff)
gentoo auto-resync : 21:09:2024 - 12:11:53
Diffstat (limited to 'dev-python/pytest-httpx')
-rw-r--r--dev-python/pytest-httpx/Manifest2
-rw-r--r--dev-python/pytest-httpx/pytest-httpx-0.31.0.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pytest-httpx/Manifest b/dev-python/pytest-httpx/Manifest
index 03f6526ccf8a..0f1dc6031e20 100644
--- a/dev-python/pytest-httpx/Manifest
+++ b/dev-python/pytest-httpx/Manifest
@@ -1,3 +1,5 @@
DIST pytest-httpx-0.30.0.tar.gz 36959 BLAKE2B b56f0e51558ffa6eb0c0af61aa3633a8e358f8c78916d101f1de853f683136a68e195bf0af099bbc6766198b4136a560ffd2676d9a49f0b350882896a61d935a SHA512 6aadb544bda5003156bf9c0fa309a166636dc87aea033d9a48ee10e1e8b77e6cb52350930e97cab89cff7c10111d5e26d1d74cd33f0a6c54e34c3fb7ef72ea05
+DIST pytest_httpx-0.31.0.tar.gz 38352 BLAKE2B 0e9ad5507ad4fe209dcf6a0b0077b0a16eb534fd3c6abe0f2e89f8b1bdc4761274e200ed8497da6df89778cccbea4af6ed06ca5fa61ba4cdd9b1164d540a09be SHA512 4c2fa27b0a6f4677dd237bd10661e668c1cb587ffa8196c715a4a66d85c47007813687b27afc217a6e20deb2b5ab013fa4b43bfe41590b6b17fdd85370aee34a
EBUILD pytest-httpx-0.30.0.ebuild 708 BLAKE2B bd19d65739a6fcc9ccadc1f7d155eadd57e99750b8fd0d47e7b46e406888f4695f605ed2690faf221778190774fc5e60f3f34f19de1b8cc78532607123b0b647 SHA512 6569e9aaabe08d24dd1752a414b272d79b6eb5f2074f26fb3612967103d7678aecf50649ace25006b22be9ca8a7d9289d19894c477245e4db1e22a1dbd12f176
+EBUILD pytest-httpx-0.31.0.ebuild 692 BLAKE2B 6fd45b0b7055784cd302e6a61e8abe8926f91f0d4eb6d5ede9419220a8734bd9b908058cd28f4fa02de243fba247f5565627366835bddc94c0b9bf988dc40924 SHA512 a4cba1fa18b697b533d948b0511efa03fb00eedfda23f6e02f41f32870e6b5b59dbca8f31827bb1ea13aa6780682fdeec740012d8d6ce504db989cb17848c4fb
MISC metadata.xml 468 BLAKE2B e0f824f05936a831a958b027366ba18cad85307ac6c81b74b299f58270bcff53e06f32b2471d6433bd7014ffde83ddb24f787c07632453d14f4ee6e4679ffd10 SHA512 16bf024801db3c0d7b789cd1f16520a1ff2520e8b3e2abbeeff5b1192c19b8ac64f55fa678c922f8a817debcfe05242ce11e0164a00422445d7301858718b359
diff --git a/dev-python/pytest-httpx/pytest-httpx-0.31.0.ebuild b/dev-python/pytest-httpx/pytest-httpx-0.31.0.ebuild
new file mode 100644
index 000000000000..eab60d4c7025
--- /dev/null
+++ b/dev-python/pytest-httpx/pytest-httpx-0.31.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Send responses to HTTPX using pytest"
+HOMEPAGE="
+ https://colin-b.github.io/pytest_httpx/
+ https://github.com/Colin-b/pytest_httpx/
+ https://pypi.org/project/pytest-httpx/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ =dev-python/httpx-0.27*[${PYTHON_USEDEP}]
+ =dev-python/pytest-8*[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest