summaryrefslogtreecommitdiff
path: root/dev-python/pytest-jupyter
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-31 10:04:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-03-31 10:04:50 +0100
commitf8b05ca448cdc580f580ff86eb8bef367d67c9ae (patch)
treeb11f11ae6a7fee98b05350f8cc542402aeb23d95 /dev-python/pytest-jupyter
parent15d97fe857a00a52fd4efb0a31ed0560f9de3a24 (diff)
gentoo auto-resync : 31:03:2023 - 10:04:50
Diffstat (limited to 'dev-python/pytest-jupyter')
-rw-r--r--dev-python/pytest-jupyter/Manifest5
-rw-r--r--dev-python/pytest-jupyter/metadata.xml17
-rw-r--r--dev-python/pytest-jupyter/pytest-jupyter-0.6.2.ebuild30
-rw-r--r--dev-python/pytest-jupyter/pytest-jupyter-0.7.0.ebuild34
4 files changed, 86 insertions, 0 deletions
diff --git a/dev-python/pytest-jupyter/Manifest b/dev-python/pytest-jupyter/Manifest
new file mode 100644
index 000000000000..ef5befe10a13
--- /dev/null
+++ b/dev-python/pytest-jupyter/Manifest
@@ -0,0 +1,5 @@
+DIST pytest_jupyter-0.6.2.tar.gz 15174 BLAKE2B b6c536383ab1b8e375e4250b4922ac6372f850ee4993643122896092109d3f711f91ccc7b159b7330de18f7876df818dc01d31c05e3c18d97488255e063db4d4 SHA512 396f7a7c978097e6dee37ead92bb3c8cef2a8100a7cc85b0b1eab19e20bdaed3332391c17568a6a279ab6ddeea1fbb2fa8dafe24ba4500982ba52cfcda2b1052
+DIST pytest_jupyter-0.7.0.tar.gz 15507 BLAKE2B b4b580668083e46830d06908f484f221e511a9dc5b32285de25e8e83268a1cb4a110ab5bc92c4652033bd658332c6aef8560313e041d39ceeec6d7339c67b24d SHA512 5bd44d1cc927281823ab92f5e1dbb4fa66e917fb9ba098c63001bb9edf60d4eb7842d4178c1dce1772e156d871def2319d511187185fbfd81ee9128c7c23ea2a
+EBUILD pytest-jupyter-0.6.2.ebuild 723 BLAKE2B f2404d1548ecfd860f3aa56fb375ed5bdcbef6896e892ff92f56284dcb1550b5e29faba02b26ccfa1cf893acc643eede70532290bb5911cc6b67d6f235918135 SHA512 68edc9e745c4af900b0cb76847f01d8f68f255b5e0f1ac89c381a3b4aee8329d2c120a8f85813f5e17a2d35e79bb9a4c52c3f7a4f5cb4f4f56f0049bfafd9222
+EBUILD pytest-jupyter-0.7.0.ebuild 828 BLAKE2B d582a142366cdd9ab51062c75ce3bfbad4104390819f93d0c5458d7b599a3e587ea8a6a843b267cea320db86eb1eb9f276b30248f4233c5c6afe9024ac5cdc05 SHA512 22ee60d3711858445837f726dac2a070d51a4956891e9ccbd6540724b6e8e6b976db8eab37129a98abcc7327947e6106d51473df00b1bc127d634f7ed7316e3b
+MISC metadata.xml 544 BLAKE2B 2774989bbb5ea75c4254ec2c9f3daf04a48bdec28698d62afd2471abb4031273bea581c09151efa643fc691a3fda2e1a4211dca66882fe2c5a24d7a6bef7c1a1 SHA512 e3751515a8baf2b422cb680870adbe9393d37ecf2e8b01212bcfa7d0b62ca368c34a9140945e1af4d7c7f0c5443b996ac7cbd4394833aa13b4e937b05bfe0e6b
diff --git a/dev-python/pytest-jupyter/metadata.xml b/dev-python/pytest-jupyter/metadata.xml
new file mode 100644
index 000000000000..8d9f695ec9a1
--- /dev/null
+++ b/dev-python/pytest-jupyter/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">pytest-jupyter</remote-id>
+ <remote-id type="github">jupyter-server/pytest-jupyter</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-jupyter/pytest-jupyter-0.6.2.ebuild b/dev-python/pytest-jupyter/pytest-jupyter-0.6.2.ebuild
new file mode 100644
index 000000000000..d19d19f131bd
--- /dev/null
+++ b/dev-python/pytest-jupyter/pytest-jupyter-0.6.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pytest plugin for testing Jupyter libraries and extensions"
+HOMEPAGE="https://jupyter.org"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
+
+RDEPEND="
+ >=dev-python/jupyter_client-7.4.0[${PYTHON_USEDEP}]
+ >=dev-python/ipykernel-6.14[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-server-1.21[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-5.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/pytest-jupyter/pytest-jupyter-0.7.0.ebuild b/dev-python/pytest-jupyter/pytest-jupyter-0.7.0.ebuild
new file mode 100644
index 000000000000..6ba7fd839d96
--- /dev/null
+++ b/dev-python/pytest-jupyter/pytest-jupyter-0.7.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pytest plugin for testing Jupyter libraries and extensions"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter-server/pytest-jupyter/
+ https://pypi.org/project/pytest-jupyter/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/jupyter_client-7.4.0[${PYTHON_USEDEP}]
+ >=dev-python/ipykernel-6.14[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-server-1.21[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-5.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest