summaryrefslogtreecommitdiff
path: root/dev-python/pytest-lazy-fixtures
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-26 06:49:21 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-26 06:49:21 +0000
commit3e90fd411cb5f48da3f2487a4ea0efcbee2bfa08 (patch)
tree7c9660a764d1acdb90fea6ec5c4f6807eaebaf4c /dev-python/pytest-lazy-fixtures
parent4dec849539ecb0ceab14d66af84960f01b9a284c (diff)
gentoo auto-resync : 26:01:2025 - 06:49:21
Diffstat (limited to 'dev-python/pytest-lazy-fixtures')
-rw-r--r--dev-python/pytest-lazy-fixtures/Manifest2
-rw-r--r--dev-python/pytest-lazy-fixtures/pytest-lazy-fixtures-1.1.2.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pytest-lazy-fixtures/Manifest b/dev-python/pytest-lazy-fixtures/Manifest
index 32d790969d30..e74f58030932 100644
--- a/dev-python/pytest-lazy-fixtures/Manifest
+++ b/dev-python/pytest-lazy-fixtures/Manifest
@@ -1,3 +1,5 @@
DIST pytest_lazy_fixtures-1.1.1.tar.gz 6978 BLAKE2B 975f76783a224c5f1237546108c25936a3fc5f6f466e936f506957675f220cf200dd0bb4f516e361fb56795281951b4196e1e7f1f399bf15dd9337766eb611a0 SHA512 b8b215f16414ddfd2f6c16b1eb8f10cc6b9931ff44f7a0a158e721071160d94e550336e785d1b5ab772ccc2a88c08687c3e5bdcf684c5e496630f341ba8b423d
+DIST pytest_lazy_fixtures-1.1.2.tar.gz 7231 BLAKE2B e3754f48501cc1908af4b733a40adb948926800d7921addb8510eeddb44c613cb80ed00044a5cef45145d8bc2c3ebda31c536facc1a4db11cdf7d8f1ef5250e9 SHA512 f9c80c77c6ea72f31817e42eab54816aefab5dade1a56ba335bc95e64ad3b48abf44f8e86c8c4c19b83bc1f51c4c15d1256df97ab9db20ee9a1266362b94f679
EBUILD pytest-lazy-fixtures-1.1.1.ebuild 697 BLAKE2B a9bdc43003f5993356797c33ec12a4377910fc76dadf2fd7927a74d5d28a3591a2012502468b6e32b951ccc017d8a4c6b4d704c5963f9d9285d65088c84b5309 SHA512 2797e1d2383858006eb5213e5aed6c9b2a62b1358b91c92c61faa6ab1991d8527c9dd61d1c38c44274b5650c72b5454d21589ea10da68ab09e120c74a1eaba30
+EBUILD pytest-lazy-fixtures-1.1.2.ebuild 707 BLAKE2B 011d9498d7e598bf98663e5df22a267a953793f0561c8e4573ac36bedd8b7891ecfb7664425dc9b8b8c7819286c072d224650d1c5d9a35cf20804a2600146ed3 SHA512 793aaa0949d9d461258d4e612da7026c00db7818a7eed39356026d7f926873f627b502be4c9e376b2a677eb5c7660041e55fc56c622f4540ab2dff0b88d96aff
MISC metadata.xml 397 BLAKE2B 99b31408b673a22388daa05cfe76d1f44e94e684dc14717d2a403e1734b703cabc100d687e888bd7c36df54fb49128b849ad6817bdcf01f1c36e497c32106427 SHA512 f5f34da24f19be54a81e06235102712399cd253b2981e7d01aedf730891cdf55cbaf816d99a0ef09b108475db79f05d940cd8b0487f5b9fc0c399fe29ba7ae95
diff --git a/dev-python/pytest-lazy-fixtures/pytest-lazy-fixtures-1.1.2.ebuild b/dev-python/pytest-lazy-fixtures/pytest-lazy-fixtures-1.1.2.ebuild
new file mode 100644
index 000000000000..d133e84e3f6b
--- /dev/null
+++ b/dev-python/pytest-lazy-fixtures/pytest-lazy-fixtures-1.1.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2024-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Allows you to use fixtures in @pytest.mark.parametrize"
+HOMEPAGE="
+ https://github.com/dev-petrov/pytest-lazy-fixtures/
+ https://pypi.org/project/pytest-lazy-fixtures/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/pytest-7[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_lazy_fixtures.plugin
+ epytest
+}