summaryrefslogtreecommitdiff
path: root/dev-python/pytest-localftpserver/pytest-localftpserver-1.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-15 05:27:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-15 05:27:58 +0100
commit90cc39f2232ae2db1954af4df82965ad2960c174 (patch)
tree40a69f630c68a907a2114e099b74df3d4024bb8c /dev-python/pytest-localftpserver/pytest-localftpserver-1.2.0.ebuild
parent2f3183511d8fcc1dd014e08f7c2535790512213d (diff)
gentoo auto-resync : 15:10:2023 - 05:27:58
Diffstat (limited to 'dev-python/pytest-localftpserver/pytest-localftpserver-1.2.0.ebuild')
-rw-r--r--dev-python/pytest-localftpserver/pytest-localftpserver-1.2.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pytest-localftpserver/pytest-localftpserver-1.2.0.ebuild b/dev-python/pytest-localftpserver/pytest-localftpserver-1.2.0.ebuild
new file mode 100644
index 000000000000..b7855edd8d14
--- /dev/null
+++ b/dev-python/pytest-localftpserver/pytest-localftpserver-1.2.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A PyTest plugin which provides an FTP fixture for your tests"
+HOMEPAGE="
+ https://github.com/oz123/pytest-localftpserver/
+ https://pypi.org/project/pytest-localftpserver/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/pyftpdlib[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+EPYTEST_IGNORE=(
+ # These tests require python wget module
+ tests/test_pytest_localftpserver.py
+ tests/test_pytest_localftpserver_TLS.py
+ tests/test_pytest_localftpserver_with_env_var.py
+)
+
+distutils_enable_tests pytest