summaryrefslogtreecommitdiff
path: root/dev-python/pytest-metadata/pytest-metadata-2.0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-31 21:06:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-10-31 21:06:00 +0000
commitc9c609463fab9bcfb35694627bca1429a21fdbb2 (patch)
tree024860c3c54aa33cdb6972acd3e2e0b8484f3aa7 /dev-python/pytest-metadata/pytest-metadata-2.0.4.ebuild
parent6dd9db91dd6ce9bbe3197aa82642866e637ba68d (diff)
gentoo auto-resync : 31:10:2022 - 21:05:59
Diffstat (limited to 'dev-python/pytest-metadata/pytest-metadata-2.0.4.ebuild')
-rw-r--r--dev-python/pytest-metadata/pytest-metadata-2.0.4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pytest-metadata/pytest-metadata-2.0.4.ebuild b/dev-python/pytest-metadata/pytest-metadata-2.0.4.ebuild
new file mode 100644
index 000000000000..9d0247fc2385
--- /dev/null
+++ b/dev-python/pytest-metadata/pytest-metadata-2.0.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A plugin for pytest that provides access to test session metadata"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-metadata/
+ https://pypi.org/project/pytest-metadata/
+"
+SRC_URI="
+ https://github.com/pytest-dev/pytest-metadata/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ <dev-python/pytest-8[${PYTHON_USEDEP}]
+ >=dev-python/pytest-7.1.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-6.2.3[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}