summaryrefslogtreecommitdiff
path: root/dev-python/pytest-mock
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /dev-python/pytest-mock
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'dev-python/pytest-mock')
-rw-r--r--dev-python/pytest-mock/Manifest2
-rw-r--r--dev-python/pytest-mock/pytest-mock-3.8.2.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/pytest-mock/Manifest b/dev-python/pytest-mock/Manifest
index fc27bfe9f227..2ef791f88094 100644
--- a/dev-python/pytest-mock/Manifest
+++ b/dev-python/pytest-mock/Manifest
@@ -1,5 +1,7 @@
DIST pytest-mock-3.7.0.tar.gz 29311 BLAKE2B 27227b66008c70c4016c8e15d0021a67e84730a8b49c5664dc4f29e16d5f163df293269ab332707e44b7a0b182e15e20ab0ebaf4b9d923eb911083377972dad1 SHA512 6ba69e86bac8a430a9f1f1c615ad21f505b87848ac50fc551bc02f81306bf8769fd015615d96085d87d4c695c24b0686a95116721358687b48b64de5d0ae6901
DIST pytest-mock-3.8.1.tar.gz 27671 BLAKE2B 6bb4a3d752ae0f4e751cb50fd6018802bb7f3cee53429693161185ef369bad8addd8637d2526750fcf9ddbe9205da3d1d615efa19b1d58ae71603ca3902c67a6 SHA512 db8c0e2cbb7f8741569035a4e6ab9335ec0b03e05f0df07de0de8dad769974f96752c15d85c439da432623b51296b88970e3e29a212930e2bac33ed47d6055f3
+DIST pytest-mock-3.8.2.tar.gz 27734 BLAKE2B feaa92ba63626d7510008c41491bd0ab649b2a0cb55c888a472a5f6100a18d8b4a232532b6b3a860483bfd1676fc1216ca368e215b8f11fc6211eeef62f5743f SHA512 039342de6a22921ebac3f54a1f217a7a5d4cf9833ce4b4bee0a18ba5409d46211cd2d9ff9620a1576560d32f5e5799483e6686e3b58d32123f41dcd7a862154b
EBUILD pytest-mock-3.7.0.ebuild 1059 BLAKE2B a16270f47039f3c785b0ab4887a8d254ef0c2ddbd9f3f47eee3c836aa306bd6c753527b46000a27cd52828ab721314b334e27b5058cb807316f6148cf7768248 SHA512 3c944b84e9242582e3e773d491d732bb16952e53e1948a73eb475d11420dc040042552b23048124dc43a709d8fbf3982bf645ed2e95ae2642596be1b1d3fa09b
EBUILD pytest-mock-3.8.1.ebuild 1067 BLAKE2B 2054d7347b138717e9c83954c1c813a52b09081e375fe73de0bfa6dba9881656f54921a7a0c63d030e62abeb74c4ba4295cb58196af46801abc3e511c6dc33dc SHA512 427607c7a44bed7a2f47593ca67db71ec97f809dd91ceba04cd4fac564f041a22aa1d7d4ba0dd544bbbe465a4db21c6c4487bf4d857b1ac9b4777f91d495fdb4
+EBUILD pytest-mock-3.8.2.ebuild 1067 BLAKE2B 2054d7347b138717e9c83954c1c813a52b09081e375fe73de0bfa6dba9881656f54921a7a0c63d030e62abeb74c4ba4295cb58196af46801abc3e511c6dc33dc SHA512 427607c7a44bed7a2f47593ca67db71ec97f809dd91ceba04cd4fac564f041a22aa1d7d4ba0dd544bbbe465a4db21c6c4487bf4d857b1ac9b4777f91d495fdb4
MISC metadata.xml 379 BLAKE2B 47a45606cecad3ecc9b902d9ec690c33a89728ce93038433f11ab8c3369089ef12e86c793ab06dedeef7a816dc973ae8ea2a6b717b13085c7912d69bcd68db65 SHA512 b5e43e5e0a1cfba50868ca542b00d40084aeb38f764f203ed112a9359e966e94d34a99bbb072b98f9401a0383d3fbf834b8b87572e073592263f18d73f09db2e
diff --git a/dev-python/pytest-mock/pytest-mock-3.8.2.ebuild b/dev-python/pytest-mock/pytest-mock-3.8.2.ebuild
new file mode 100644
index 000000000000..ce9187b4e2e5
--- /dev/null
+++ b/dev-python/pytest-mock/pytest-mock-3.8.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Thin-wrapper around the mock package for easier use with pytest"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-mock/
+ https://pypi.org/project/pytest-mock/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/pytest-6[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_mock,pytest_asyncio.plugin
+ local EPYTEST_DESELECT=()
+
+ if has_version dev-python/mock; then
+ EPYTEST_DESELECT+=(
+ tests/test_pytest_mock.py::test_standalone_mock
+ )
+ fi
+
+ epytest --assert=plain
+}