summaryrefslogtreecommitdiff
path: root/dev-python/pytest-mock
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/pytest-mock
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/pytest-mock')
-rw-r--r--dev-python/pytest-mock/Manifest2
-rw-r--r--dev-python/pytest-mock/pytest-mock-3.7.0.ebuild19
2 files changed, 14 insertions, 7 deletions
diff --git a/dev-python/pytest-mock/Manifest b/dev-python/pytest-mock/Manifest
index 200c27dbc4b1..ef6f9debec3c 100644
--- a/dev-python/pytest-mock/Manifest
+++ b/dev-python/pytest-mock/Manifest
@@ -1,3 +1,3 @@
DIST pytest-mock-3.7.0.tar.gz 29311 BLAKE2B 27227b66008c70c4016c8e15d0021a67e84730a8b49c5664dc4f29e16d5f163df293269ab332707e44b7a0b182e15e20ab0ebaf4b9d923eb911083377972dad1 SHA512 6ba69e86bac8a430a9f1f1c615ad21f505b87848ac50fc551bc02f81306bf8769fd015615d96085d87d4c695c24b0686a95116721358687b48b64de5d0ae6901
-EBUILD pytest-mock-3.7.0.ebuild 979 BLAKE2B fdb2b71603cd10eebbd82fb755ba9464c84346a52e69bf6e5d49b2a4cc2c95318daac5c0fcf896dfbee09a54985b5db5cbec6cd6167ea8e0054457aadc9245aa SHA512 3bce72823e1094dcb7866b093dc176b2d58f44d83c012cad4b433ef885e7c2df68cb2180e99c1e818ff00d0351b0e011cb2d9ed5fde6014dd67622fe4c3e52b5
+EBUILD pytest-mock-3.7.0.ebuild 1059 BLAKE2B a16270f47039f3c785b0ab4887a8d254ef0c2ddbd9f3f47eee3c836aa306bd6c753527b46000a27cd52828ab721314b334e27b5058cb807316f6148cf7768248 SHA512 3c944b84e9242582e3e773d491d732bb16952e53e1948a73eb475d11420dc040042552b23048124dc43a709d8fbf3982bf645ed2e95ae2642596be1b1d3fa09b
MISC metadata.xml 379 BLAKE2B 47a45606cecad3ecc9b902d9ec690c33a89728ce93038433f11ab8c3369089ef12e86c793ab06dedeef7a816dc973ae8ea2a6b717b13085c7912d69bcd68db65 SHA512 b5e43e5e0a1cfba50868ca542b00d40084aeb38f764f203ed112a9359e966e94d34a99bbb072b98f9401a0383d3fbf834b8b87572e073592263f18d73f09db2e
diff --git a/dev-python/pytest-mock/pytest-mock-3.7.0.ebuild b/dev-python/pytest-mock/pytest-mock-3.7.0.ebuild
index 8eb86230165a..6266e8ce070c 100644
--- a/dev-python/pytest-mock/pytest-mock-3.7.0.ebuild
+++ b/dev-python/pytest-mock/pytest-mock-3.7.0.ebuild
@@ -4,33 +4,40 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
inherit distutils-r1
DESCRIPTION="Thin-wrapper around the mock package for easier use with pytest"
-HOMEPAGE="https://github.com/pytest-dev/pytest-mock/"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-mock/
+ https://pypi.org/project/pytest-mock/
+"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv sparc x86 ~x64-macos"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
RDEPEND="
- >=dev-python/pytest-6[${PYTHON_USEDEP}]"
+ >=dev-python/pytest-6[${PYTHON_USEDEP}]
+"
BDEPEND="
dev-python/setuptools_scm[${PYTHON_USEDEP}]
test? (
dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- )"
+ )
+"
distutils_enable_tests pytest
python_test() {
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
local -x PYTEST_PLUGINS=pytest_mock,pytest_asyncio.plugin
+ local EPYTEST_DESELECT=()
if has_version dev-python/mock; then
- local EPYTEST_DESELECT=(
+ EPYTEST_DESELECT+=(
tests/test_pytest_mock.py::test_standalone_mock
)
fi